Unable to install the new Java helper class in AEM 6.5.3 after upgrade from AEM 6.3

Avatar

Avatar

GokulBakthavachalam

Avatar

GokulBakthavachalam

GokulBakthavachalam

16-08-2020

Hi All,

 

I am seeing issues while trying to install the Java helper class in AEM 6.5.3 version. This issues is in particular with the newly created helper classes in 6.5.3 version whereas the ones created in 6.3. version seems to be working without issues.

Also, I am unable to read the page properties while doing enhancements in the clases in 6.5.3 version originally created in 6.3 version.

I did check in the system console bundle but could not find the newly created models. Could this be related to POM.xml files? Please advise

 

Thanks,

Gokul B 

View Entire Topic

Avatar

Avatar

Nikhil-Kumar

MVP

Avatar

Nikhil-Kumar

MVP

Nikhil-Kumar
MVP

17-08-2020

@GokulBakthavachalam ,

Try checking for the bundle's dependency on felix console. I am pretty sure that most of the dependencies will be in red.
Update your dependencies as per the new version of AEM 6.5 SP3 and try to resolve all the dependencies of felix console.

I migrated from AEM 6.4.3 to 6.5.5, faced similar issue, but in my case it got resolved by updating the dependencies of adobe libraries in react-app code in package.json file. So if you are using AEM with React, then try to upgrade those dependencies as well.
But at last option of upgrading dependencies paid me off!!.

Happy Coding!!