Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Unable to Edit any page of We.Retail or newly created page in We.Retail

Avatar

Level 2

Hi,

 

I have just started learning AEM. I have setup and installed AEM 6.5.

When i created a new page in Site, page got created successfully but when i tried to edit the page by following UI steps, it opens up in different tab name AEM Editor but didn't give any option to edit or add something on the page. Please see screen shot for your reference -

AEM Editor - Unable to Edit the pageAEM Editor - Unable to Edit the page

When i opened the console, get error "Uncaught SyntaxError: Invalid or unexpected token" page.js: 36118

Console error page.PNG

I have tried to search for help in community, as i came to know that it seems some library or package or any other dependency is missing.

Please help me in this, and if i need to add some libs please help me with the steps or reference.

Many thanks in advance.

have a good day.

1 Accepted Solution

Avatar

Correct answer by
Level 2

Hi All,

 

Many thanks for all your help.

It is working fine now. I have just updated jdk 11 from jdk 8. I have restarted system but it was not working yesterday. today i started again and it is working fine. I am able to edit the page.

many thanks for your overwhelming responses, help and support.

Good to be a part of such a supportive comminity.

Thanks!

View solution in original post

7 Replies

Avatar

Community Advisor

Hi @srma4tech_Sachin,

 

go to http://localhost:4502/system/console/bundles (system console) and check if all bundles are active, if not see what dependencies it is missing.

 

 

Avatar

Level 2

Hi @B_Sravan ,

Many thanks for your response and looking into it.

I have checked all the bundles status, all are active except three which status is shown as "Fragment".

Please see screen shot below for your reference -

bundle Status.PNG

Please let me know if anything needs to be validated. I am also attaching the error logs in @Ravi_Pampana 's reply. please have a loo.

Many thanks for your response.

Regards,

Sachin

Avatar

Community Advisor

Hi,

Did you check if there are any errors in /crx-quickstart/logs/error.log ? Checking here will give lead to why the page is loading blank.

Also, are you using admin user for login or created custom user ? 

Avatar

Level 5

@srma4tech_Sachin please check error.log as mentioned by @Ravi_Pampana.

I think you are trying to open 'we-retail/us' page which will redirect to English page, 'we-retail/us/en'. Are you not seeing the redirect option on the screen like the below screenshot? Seems like your page did not load completely since I don't see the 'Toggle side panel' option on the top left corner.

 

Ganthimathi_0-1663439310923.png

 

Avatar

Level 2

Exactly, it is not loading properly, actually i have started learning AEM yesterday itself, so didn't have much knowledge as of now. I have created new page in we.retail "Demo", it also didn't gives toggle option -

srma4tech_Sachin_0-1663440500914.png

from error logs i am unable to rectify what is wrong.. could you please help me with an approach to fix it.

Many thanks for help and response.

Avatar

Correct answer by
Level 2

Hi All,

 

Many thanks for all your help.

It is working fine now. I have just updated jdk 11 from jdk 8. I have restarted system but it was not working yesterday. today i started again and it is working fine. I am able to edit the page.

many thanks for your overwhelming responses, help and support.

Good to be a part of such a supportive comminity.

Thanks!