Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Unable to create node from eclipse.

akashs51893872
Level 3
Level 3

Hello,

I am trying to create a node from the Eclipse Oxygen IDE.  Am unable to create a node as it gives the following error:1294889_pastedImage_0.png

Please help.

Thanks & Regards

1 Accepted Solution
Ratna_Kumar
Correct answer by
Community Advisor
Community Advisor

Hi Akash,

If you see that type of error you can fix by this below example screenshot.

Error.PNG

Here this is beautifully explained here: Getting Started with AEM Sites Part 2 - Creating a Base Page and Template . I have got the same issue and fixed by using above screenshot.

Hope this helps!!

~Ratna.

View solution in original post

10 Replies
Prince_Shivhare
Community Advisor
Community Advisor

Hi,

Please create a node from CRXDE and import it to Eclipse by AEM server.

This is the best practice we followed.

Regards,
Prince

akashs51893872
Level 3
Level 3

This is a good idea; however, it will be great if we can create nodes from outside of CRXDE....

akashs51893872
Level 3
Level 3

Also, could you please give some reference of steps on how to `import it to Eclipse by AEM server`?

Diego_Fontan
Level 4
Level 4

you can check how to use  development tools for AEM project(create a node, debug, etc): Development Tools

Some examples:

Note: In my experience Brackets it could be tricky and hard in some occasion but the other tools works very well for all team member.

Veena_Vikram
Community Advisor
Community Advisor

You can do it. It is always achievable , but the error message displayed  seems like your eclipse is not able to communicate to the server. Moreover, if there is any error in the type of the node, it will always throw error and won't let you create one.

akash143143143
Level 2
Level 2

Here's a larger screenshot of the issue which shows that the server is connected and synchronized.

1295941_pastedImage_2.png

Please suggest.

Ratna_Kumar
Correct answer by
Community Advisor
Community Advisor

Hi Akash,

If you see that type of error you can fix by this below example screenshot.

Error.PNG

Here this is beautifully explained here: Getting Started with AEM Sites Part 2 - Creating a Base Page and Template . I have got the same issue and fixed by using above screenshot.

Hope this helps!!

~Ratna.

View solution in original post

akash143143143
Level 2
Level 2

Hello,

Most of the times, for some unknown reason, it is not possible to create a node from Eclipse.  The steps to create nodes on Eclipse project are as follows:-

Step 1: Create Template in CRXde as usual.

Step 2: Import in Eclipse project.  Right-click on the jcr:root or rep:root folder and click on Import from server...

1309336_pastedImage_4.png

Additional notes :

  1. AEM Server needs to be setup on Eclipse environment. (Eclipse AEM Plugin is available for that)
  2. Suggest you to save your changes before 'importing' as those changes may be irreversible.

Good Luck.