Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Unable to access repo.adobe.com via maven

Avatar

Level 3

Hi am getting following error.

  1. Failed to read artifact descriptor for com.adobe.aem:aem-api:jar:6.0.0.1: Could not transfer artifact com.adobe.aem:aem-api:pom:6.0.0.1 from/to adobe (http://repo.adobe.com/nexus/content/groups/public/): Received fatal alert: handshake_failure.
  2.  

Tried for creating sightly component using this link   https://helpx.adobe.com/experience-manager/using/creating-sightly-component.html

 

Showing error as

[INFO] Building Sightly Bundle 1.0-SNAPSHOT
[INFO] ------------------------------------------------------------------------
Downloading: https://repo.adobe.com/nexus/content/groups/public/com/adobe/aem/aem-api/6.0.0.1/aem-api-6.0.0.1.pom
Downloading: http://repo.adobe.com/nexus/content/groups/public/com/adobe/aem/aem-api/6.0.0.1/aem-api-6.0.0.1.pom
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
[INFO] Sightly Training Package - Reactor Project ........ SUCCESS [0.315s]
[INFO] Sightly Bundle .................................... FAILURE [1.593s]
[INFO] Sightly Training Package Package .................. SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2.932s
[INFO] Finished at: Tue Jun 23 17:34:54 IST 2015
[INFO] Final Memory: 8M/122M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project sightly-bundle: Could not resolve dependencies for project com.mycompany.myproject.sightly:sightly-bundle:jar:1.0-SNAP
SHOT: Failed to collect dependencies at com.adobe.aem:aem-api:jar:6.0.0.1: Failed to read artifact descriptor for com.adobe.aem:aem-api:jar:6.0.0.1: Could not t
ransfer artifact com.adobe.aem:aem-api:pom:6.0.0.1 from/to adobe-public-releases (https://repo.adobe.com/nexus/content/groups/public): peer not authenticated ->
 [Help 1]

 

Thanks,

Kumar.

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hi,

adobe repo url is now made secured. so change

http://repo.adobe.com/nexus/content/groups/public/ to https://repo.adobe.com/nexus/content/groups/public/

View solution in original post

2 Replies

Avatar

Correct answer by
Community Advisor

Hi,

adobe repo url is now made secured. so change

http://repo.adobe.com/nexus/content/groups/public/ to https://repo.adobe.com/nexus/content/groups/public/

Avatar

Administrator

Instructions on how to use repo are displayed on https://repo.adobe.com/index.html

Please use "https" protocol instead of "http"

Also, have a look at: https://experienceleague.adobe.com/docs/experience-cloud-kcs/kbarticles/KA-17454.html?lang=en