Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Two bundles looking for same package, but different versions

Avatar

Avatar
Validate 1
Level 2
Srinin
Level 2

Like

1 like

Total Posts

22 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 2
Srinin
Level 2

Like

1 like

Total Posts

22 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
Srinin
Level 2

30-03-2017

Hi,

I have this ERROR:

org.osgi.framework.BundleException: Uses constraint violation. Unable to resolve bundle revision com.sample.test-wcm-bundle [397.825] because it is exposed to package 'org.apache.commons.lang.math' from bundle revisions com.sample.test-wcm-dependencies-bundle [398.824] and com.day.commons.osgi.wrapper.commons-lang2 [45.0] via two dependency chains.

com.day.commons.osgi.wrapper.commons-lang2 has commons-lang version 2.5, 

My bundle com.sample.test-wcm-dependencies-bundle needs commons-lang version 2.6.

How to resolve this?

thanks

Srini 

View Entire Topic

Avatar

Avatar
Validate 1
Level 2
Srinin
Level 2

Like

1 like

Total Posts

22 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 2
Srinin
Level 2

Like

1 like

Total Posts

22 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
Srinin
Level 2

31-03-2017

Hi Scott,

Thanks for your reply. Here we have two bundles, which bundle you were talking about?

com.day.commons.osgi.wrapper.commons-lang2 OR  com.sample.test-wcm-dependencies-bundle ?

com.sample.test-wcm-dependencies-bundle generates every time I do the build. So we can't change Manifest every time here.

So, I think, you were referring this com.day.commons.osgi.wrapper.commons-lang2.

thanks

Srini