Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Two bundles looking for same package, but different versions

Srinin
Level 2
Level 2

Hi,

I have this ERROR:

org.osgi.framework.BundleException: Uses constraint violation. Unable to resolve bundle revision com.sample.test-wcm-bundle [397.825] because it is exposed to package 'org.apache.commons.lang.math' from bundle revisions com.sample.test-wcm-dependencies-bundle [398.824] and com.day.commons.osgi.wrapper.commons-lang2 [45.0] via two dependency chains.

com.day.commons.osgi.wrapper.commons-lang2 has commons-lang version 2.5, 

My bundle com.sample.test-wcm-dependencies-bundle needs commons-lang version 2.6.

How to resolve this?

thanks

Srini 

1 Accepted Solution
Jörg_Hoh
Correct answer by
Employee
Employee

Hi,

the sample works here on AEM 6.2, the april-project bundle ist active.

Jörg

View solution in original post

12 Replies
smacdonald2008
Level 10
Level 10

All you need to do is open the bundle and modify the Manifest file to point to the correct version of a specific package. 

Srinin
Level 2
Level 2

Hi Scott,

Thanks for your reply. Here we have two bundles, which bundle you were talking about?

com.day.commons.osgi.wrapper.commons-lang2 OR  com.sample.test-wcm-dependencies-bundle ?

com.sample.test-wcm-dependencies-bundle generates every time I do the build. So we can't change Manifest every time here.

So, I think, you were referring this com.day.commons.osgi.wrapper.commons-lang2.

thanks

Srini

Srinin
Level 2
Level 2

Hi Scott,

I am Sorry for the confusion. Here is the actual error. This com.day.cq.commons is using the old version. And this refers cq-commons-5.7.14.jar. I need to change the version Manifest of this file.

Chain 1:
  com.mynews.my-wcm-bundle [397.825]
    import: (&(osgi.wiring.package=org.apache.commons.lang.math)(version>=2.6.0)(!(version>=3.0.0)))
     |
    export: osgi.wiring.package=org.apache.commons.lang.math
  com.mynews.my-wcm-dependencies-bundle [398.824]

Chain 2:
  com.mynews.my-wcm-bundle [397.825]
    import: (osgi.wiring.package=com.day.cq.security)
     |
    export: osgi.wiring.package=com.day.cq.security; uses:=com.day.cq.commons
  com.day.cq.cq-security-api [468.0]
    import: (osgi.wiring.package=com.day.cq.commons)
     |
    export: osgi.wiring.package=com.day.cq.commons; uses:=org.apache.commons.lang.time
  com.day.cq.cq-commons [424.0]
    import: (&(osgi.wiring.package=org.apache.commons.lang.time)(version>=2.4.0)(!(version>=3.0.0)))
     |
    export: osgi.wiring.package=org.apache.commons.lang.time; uses:=org.apache.commons.lang.math
    export: osgi.wiring.package=org.apache.commons.lang.math
  com.day.commons.osgi.wrapper.commons-lang2 [45.0]
        at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3986)
        at org.apache.felix.framework.Felix.startBundle(Felix.java:2043)
        at org.apache.felix.framework.Felix$RefreshHelper.restart(Felix.java:4861)
        at org.apache.felix.framework.Felix.refreshPackages(Felix.java:4128)
        at org.apache.felix.framework.FrameworkWiringImpl.run(FrameworkWiringImpl.java:178)
        at java.lang.Thread.run(Thread.java:745)

smacdonald2008
Level 10
Level 10

When i first read that - i thought you were pointing to a wrong version that could be corrected by referencing the correct version in the MF file.

Lets take a step back. How are you building the bundle? Are you using Maven 10 Archetype and Urber 6.2?  

MC_Stuff
Level 9
Level 9

Hi Srini,

On your custom bundle embed the commons-lang version 2.6.  and exclude it to expose api.

Thanks,

Srinin
Level 2
Level 2

Hi MC,

Here are more details:

My code uses package X (AWS - 3rd party package) uses org.apache.commons.lang 2.6.0
My code uses package Y (Adobe - 3rd party package) uses org.apache.commons.lang 2.4

I can't adjust versions in either bundle X or Y. Is there anything I can do in my pom files. 

Excluding package import doesn't help.

Jörg_Hoh
Employee
Employee

Can you be more specific regarding the AWS bundle?

The typical approach for this would be to wrap the AWS bundle plus its dependencies into a custom bundle, which has not other external dependency.

Jörg

Srinin
Level 2
Level 2

Jörg,

I almost did like that only. I have a dependencies  bundle with all the 3rd party dependencies. 

My concerns are: The version conflict I talked about, is not there if I restart the author instance. But If I do the build, the version conflict issues comes back.Why?

Thanks

Srini

Srinin
Level 2
Level 2

Hello,

I am still these issues. I created a sample project here [1]. If you could import this project to Eclipse and build to your local, you can understand the issues I am facing. 

[1] https://github.com/nsrini/april-project

If you build to your local AEM, you could see that sideadmin won't respond and errors in the error.log. If anyone could resolve the errors by adjusting the pom files, I really appreciate. I use AEM 6.0 SP2.

Please let me know if you have any questions.

thanks

Srini

ethomasjoseph
Level 1
Level 1

Hi Srini,

It is bit difficult to visualise the actual dependency and the error. But try packaging your code bundle and dependencies as one bundle instead of two.

The problem here could be that when a bundle with second level dependencies which vary in version is installed, only the bundle itself is tried for a rewiring. When you restart the instance, all the bundles in the system are taken into account and attempted for a dependency rewiring.

Even in your current setup, just hit "Refresh Packages" in the Felix Console and your issue should be resolved.

HTH,

Thomas

Jörg_Hoh
Correct answer by
Employee
Employee

Hi,

the sample works here on AEM 6.2, the april-project bundle ist active.

Jörg

View solution in original post