Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

SPA React not displaying Custom Components

dexm32937298
Level 2
Level 2

I have spent a ton of time and combed through the docs to figure out this. My custom built react component is not displaying in the editor, ever. It is showing up on the http://localhost:4502/content/wknd-events/react.model.json and in the CXR/DE. Feel like I have tried everything and I am not seeing any resources for debugging this/ a workaround.  The custom-built components also do not render in ANY AEM instance but if I pull up the local build (localhost:3000) all of the items that I did add appear.

1 Accepted Solution
dexm32937298
Correct answer by
Level 2
Level 2

That helps a little with understanding the pathing that it is taking but Still nothing is working. All of the Data is in the JCR and since Adobes Docs are straight garbage when it comes to this I am not able to find anything.

View solution in original post

0 Replies
Gaurav-Behl
Community Advisor
Community Advisor

Do you mean to say that you have followed Adobe Experience Manager Help | Getting Started with React and AEM SPA Editor  and same is working fine but your own custom component in AEM?

Could you share more details about that component(s) and what version/SP of AEM do you use?

dexm32937298
Level 2
Level 2

I have gone through that walkthrough and the one that uses we-journal. On the most simple leve I have just tried to build a text component from the ground up changing names slightly to just follow my trail. Using AEM 6.5.

Gaurav-Behl
Community Advisor
Community Advisor

I can't pinpoint any issue unless I go through the code. I can try if you're willing to share the minimal code package.

SammyK267
Level 1
Level 1

Did you make sure to create the Sling Model Exporter for your custom component?

dexm32937298
Level 2
Level 2

Confused on the Sling Model Exporter, what is that?

dexm32937298
Level 2
Level 2

Thanks, That doesn't appear to be the issue but then again the docs are garbage, and the videos are not showing anything.

dexm32937298
Level 2
Level 2

Example=> jump straight to exporter, no documentation of where or how this is hooked up. 3rd Video starts with "HTL script that we showed in the last video" when there is no script. To be honest I'm just super disappointed in the little that I can find to help me out.

Gaurav-Behl
Community Advisor
Community Advisor

Not sure if you have already gone through this doc --  SPA Editor Overview

This diagram explains that if you don't rely on existing/OOB core components/Sling Models/Sling Model Exporters and build custom components then you would need to wire each entity in a correct way either using OOB models/exporters or otherwise with custom implementations.

HTH

page_editor_spa_authoringmediator-2

dexm32937298
Correct answer by
Level 2
Level 2

That helps a little with understanding the pathing that it is taking but Still nothing is working. All of the Data is in the JCR and since Adobes Docs are straight garbage when it comes to this I am not able to find anything.

View solution in original post

LaMind3
Level 2
Level 2
Hi dexm32937298, I am facing same issue. were you able to fix this issue?