Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

SegmentNodeStoreService Error while doing inplace upgrade from cq5.6.1 to AEM6.0

Avatar

Level 5

while migrating from AEM 5.6 to aem 6.0 , I am getting below mentioned error,

"17.08.2015 19:23:49.884 *ERROR* [qtp758918049-40] org.apache.sling.engine.impl.SlingHttpContext handleSecurity: AuthenticationSupport service missing. Cannot authenticate request.
17.08.2015 19:23:49.884 *ERROR* [qtp758918049-40] org.apache.sling.engine.impl.SlingHttpContext handleSecurity: Possible reason is missing Repository service. Check AuthenticationSupport dependencies."

 

after tracing logs, below is the error message that was thrown earlier

 

17.08.2015 19:18:26.790 *INFO* [FelixStartLevel] org.apache.jackrabbit.oak.plugins.segment.file.FileStore TarMK opened: C:\adobe-5.6.1\LS_BSC_SourceCode\cq5\latest tryout upgrade\crx-quickstart\repository\segmentstore (mmap=true)
17.08.2015 19:18:26.793 *DEBUG* [FelixStartLevel] org.apache.jackrabbit.oak.plugins.segment.SegmentId Loading segment 2df86d6e-4d4f-434e-ac1c-a72aeb3c8f93
17.08.2015 19:18:26.796 *ERROR* [FelixStartLevel] org.apache.jackrabbit.oak-core [org.apache.jackrabbit.oak.plugins.segment.SegmentNodeStoreService(46)] The activate method has thrown an exception (java.lang.IllegalStateException)
java.lang.IllegalStateException: null
    at com.google.common.base.Preconditions.checkState(Preconditions.java:134)
    at org.apache.jackrabbit.oak.plugins.segment.Segment.<init>(Segment.java:129)
    at org.apache.jackrabbit.oak.plugins.segment.file.FileStore.readSegment(FileStore.java:510)
    at org.apache.jackrabbit.oak.plugins.segment.SegmentTracker.getSegment(SegmentTracker.java:106)
    at org.apache.jackrabbit.oak.plugins.segment.SegmentId.getSegment(SegmentId.java:97)
    at org.apache.jackrabbit.oak.plugins.segment.Record.getSegment(Record.java:68)
    at org.apache.jackrabbit.oak.plugins.segment.SegmentNodeState.getTemplate(SegmentNodeState.java:74)
    at org.apache.jackrabbit.oak.plugins.segment.SegmentNodeState.getChildNode(SegmentNodeState.java:334)
    at org.apache.jackrabbit.oak.plugins.segment.SegmentNodeStore.getRoot(SegmentNodeStore.java:117)
    at org.apache.jackrabbit.oak.plugins.segment.SegmentNodeStore.<init>(SegmentNodeStore.java:80)
    at org.apache.jackrabbit.oak.plugins.segment.SegmentNodeStoreService.registerNodeStore(SegmentNodeStoreService.java:156)
    at org.apache.jackrabbit.oak.plugins.segment.SegmentNodeStoreService.activate(SegmentNodeStoreService.java:119)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:606)
    at org.apache.felix.scr.impl.helper.BaseMethod.invokeMethod(BaseMethod.java:231)
    at org.apache.felix.scr.impl.helper.BaseMethod.access$500(BaseMethod.java:39)
    at org.apache.felix.scr.impl.helper.BaseMethod$Resolved.invoke(BaseMethod.java:624)
    at org.apache.felix.scr.impl.helper.BaseMethod.invoke(BaseMethod.java:508)
    at org.apache.felix.scr.impl.helper.ActivateMethod.invoke(ActivateMethod.java:149)
    at org.apache.felix.scr.impl.manager.SingleComponentManager.createImplementationObject(SingleComponentManager.java:315)
    at org.apache.felix.scr.impl.manager.SingleComponentManager.createComponent(SingleComponentManager.java:127)
    at org.apache.felix.scr.impl.manager.SingleComponentManager.getService(SingleComponentManager.java:871)
    at org.apache.felix.scr.impl.manager.SingleComponentManager.getServiceInternal(SingleComponentManager.java:838)
    at org.apache.felix.scr.impl.manager.AbstractComponentManager.activateInternal(AbstractComponentManager.java:850)
    at org.apache.felix.scr.impl.manager.AbstractComponentManager.enable(AbstractComponentManager.java:419)
    at org.apache.felix.scr.impl.config.ConfigurableComponentHolder.enableComponents(ConfigurableComponentHolder.java:376)
    at org.apache.felix.scr.impl.BundleComponentActivator.initialize(BundleComponentActivator.java:172)
    at org.apache.felix.scr.impl.BundleComponentActivator.<init>(BundleComponentActivator.java:120)
    at org.apache.felix.scr.impl.Activator.loadComponents(Activator.java:258)
    at org.apache.felix.scr.impl.Activator.access$000(Activator.java:45)
    at org.apache.felix.scr.impl.Activator$ScrExtension.start(Activator.java:185)
    at org.apache.felix.utils.extender.AbstractExtender.createExtension(AbstractExtender.java:259)
    at org.apache.felix.utils.extender.AbstractExtender.modifiedBundle(AbstractExtender.java:232)
    at org.osgi.util.tracker.BundleTracker$Tracked.customizerModified(BundleTracker.java:479)
    at org.osgi.util.tracker.BundleTracker$Tracked.customizerModified(BundleTracker.java:414)
    at org.osgi.util.tracker.AbstractTracked.track(AbstractTracked.java:232)
    at org.osgi.util.tracker.BundleTracker$Tracked.bundleChanged(BundleTracker.java:443)
    at org.apache.felix.framework.util.EventDispatcher.invokeBundleListenerCallback(EventDispatcher.java:869)
    at org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:790)
    at org.apache.felix.framework.util.EventDispatcher.fireBundleEvent(EventDispatcher.java:515)
    at org.apache.felix.framework.Felix.fireBundleEvent(Felix.java:4409)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2098)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1297)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:745)
17.08.2015 19:18:26.797 *ERROR* [FelixStartLevel] org.apache.jackrabbit.oak-core 

 

Can anyone help.

1 Accepted Solution

Avatar

Correct answer by
Employee

Hi,

did you get any issues when running the cleanup tasks: Workflow purge, consistency and traversal check?

Also, your path to the AEM directoryhas spaces in it "latest tryout upgrade", can you create  path without spaces and try again?

C:\adobe-5.6.1\LS_BSC_SourceCode\cq5\latest tryout upgrade\crx-quickstart\repository\segmentstore

This is a known issue for AEM6.1, so worth trying in your AEM6 instance

Regards,

Opkar

View solution in original post

0 Replies

Avatar

Community Advisor

Are you doing inplace upgrade ? crx2 to crx3 ?

can you please give us more details on the steps you are following.

Avatar

Level 5

yes I am trying to migrate from 5.6 to 6.0,

and have followed all the steps provided in the link"http://docs.adobe.com/docs/en/aem/6-0/deploy/upgrade.html"

I was able to upgrade in-Place, and now want to migrate the repository from crx2 to oak, i have run the crx2oak tool and followed steps... what could the error be?

Avatar

Correct answer by
Employee

Hi,

did you get any issues when running the cleanup tasks: Workflow purge, consistency and traversal check?

Also, your path to the AEM directoryhas spaces in it "latest tryout upgrade", can you create  path without spaces and try again?

C:\adobe-5.6.1\LS_BSC_SourceCode\cq5\latest tryout upgrade\crx-quickstart\repository\segmentstore

This is a known issue for AEM6.1, so worth trying in your AEM6 instance

Regards,

Opkar

Avatar

Level 1

Hi Everyone,

I am also facing same problem with same error message. I followed steps mentioned in https://docs.adobe.com/docs/en/aem/6-0/deploy/upgrade.html. I am using crx2oak-1.0.42.jar. I faced problem on step 8 for Migrating to TarMK however till step 6 AEM was started and everything was accessible. After execution of step 8, I can see all bundles in felix console are active (Bundle information: 392 bundles in total - all 392 bundles active). 

Please help where i need to do changes. 

Error messages

[1] While accessing the content page / CRX

11.02.2016 13:12:01.920 *ERROR* [qtp597026431-33] org.apache.sling.engine.impl.SlingHttpContext handleSecurity: AuthenticationSupport service missing. Cannot authenticate request.
11.02.2016 13:12:01.921 *ERROR* [qtp597026431-33] org.apache.sling.engine.impl.SlingHttpContext handleSecurity: Possible reason is missing Repository service. Check AuthenticationSupport dependencies.

 

[2] While starting the AEM at step 8 of Migrating to TarMK (https://docs.adobe.com/docs/en/aem/6-0/deploy/upgrade.html#Migrating the repository to OAK)

11.02.2016 13:11:52.375 *ERROR* [FelixStartLevel] org.apache.jackrabbit.oak-core [org.apache.jackrabbit.oak.plugins.segment.SegmentNodeStoreService(46)] The activate method has thrown an exception (java.lang.IllegalStateException)
java.lang.IllegalStateException: null
    at com.google.common.base.Preconditions.checkState(Preconditions.java:134)
    at org.apache.jackrabbit.oak.plugins.segment.Segment.<init>(Segment.java:129)
    at org.apache.jackrabbit.oak.plugins.segment.file.FileStore.readSegment(FileStore.java:510)
    at org.apache.jackrabbit.oak.plugins.segment.SegmentTracker.getSegment(SegmentTracker.java:106)
    at org.apache.jackrabbit.oak.plugins.segment.SegmentId.getSegment(SegmentId.java:97)
    at org.apache.jackrabbit.oak.plugins.segment.Record.getSegment(Record.java:68)
    at org.apache.jackrabbit.oak.plugins.segment.SegmentNodeState.getTemplate(SegmentNodeState.java:74)

.........

    at java.lang.Thread.run(Unknown Source)
11.02.2016 13:11:52.375 *ERROR* [FelixStartLevel] org.apache.jackrabbit.oak-core [org.apache.jackrabbit.oak.plugins.segment.SegmentNodeStoreService(46)] Failed creating the component instance; see log for reason

 

 

 

Thanks