Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.

SAML 2.0 Authentication Handler - Rejected empty referrer header

Avatar

Level 2

hello everyone, 

I configured SAML 2.0 Authentication Handler on AEM 6.5 following https://experienceleague.adobe.com/docs/experience-manager-65/administering/security/saml-2-0-authen... for we-retail and i'm getting a 

20.02.2023 21:32:26.547 *INFO* [qtp927739593-1970] org.apache.sling.security.impl.ReferrerFilter Rejected empty referrer header for POST request to /content/we-retail.html

I see the post entering with all data and when i activate the allows empty option at apache filter, the localhost:4503/content/we-retail.html reloads multiple times. Is there any configuration that i'm missing?

k_arroyo_guzman_0-1676925482120.png

Thanks in advance

 

7 Replies

Avatar

Community Advisor

Hi @qath ,

 

This error is is due to the Apache Sling Referrer Filter will not allow empty Referrer address by default.
 
For testing purpose, you can allow empty referrer by changing the Apache Sling Referrer Filter.

Apache Sling Referrer Filter configuration

Search for "Apache Sling Referrer Filter"
Select "Allow Empty"
ChitraMadan_0-1677085296857.jpeg

 

This should be only enabled for testing purpose.
 
 

Avatar

Level 2

thanks @ChitraMadan but i tried that too and the /content/we-retail.html reloads multiple times, I starting to think that the AEM page has no complete info of all places that are needed to configure.

 

 

Avatar

Level 2

I am facing exactly the same issues. Was this ever resolved?

 

Thanks,

Avatar

Level 2

Solved with:

Apache Sling Referrer Filter"
Select "Allow Empty"

Avatar

Level 2

Thanks, but how is the multiple reloading - from /content/we-retail.html to saml login page resolved?

Avatar

Level 2

Yes, you need to check all the configuration params, in my case was because my accertion url should be a /saml_login one.

For logger works correctly you should Configure a Logger for SAML

 

Avatar

Level 1

Hi, I have got the same problem but before i check this mark im wondering for what reason it is not checked in from the start. What problems could this lead to if i check it?