Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Reverse Replication working when I freshly add cq:distribute prop

Avatar

Level 3

I am trying to demonstrate basic reverse replication on AEM 6.5.10.
Created a new reverse replication agent in author which works fine.

Created a servlet to modify page content which changes some values as well as adds the cq:distribute  property with value true.
Whenever I run the servlet and the page content get the distribute property, reverse replication works. After this If I hit the servlet again then some props change but reverse replication does not work.

When I checked the logs I found that the polling is working fine and it fetched 0 files which means there is nothing in the outbox.
Now here is the weird part -> If I delete the cq:distribute property from crx/de and run the servlet then reverse replication works.
In short: Reverse replication works only when I add the cq:distribute property to the node. If the property already exists and I change some other property then the reverse replication does not work.

 

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

@Vinit_Pillai - Checking, are you also clearing the cq:distribute property and saving session?

View solution in original post

1 Reply

Avatar

Community Advisor

Hi @Vinit_Pillai, does your servlet also modifies/updates cq:lastModifiedDate value, every time it's changing other fields?

Maybe this documentation will be also useful for you https://helpx.adobe.com/uk/experience-manager/kb/HowToUseReverseReplication.html

Avatar

Correct answer by
Community Advisor

@Vinit_Pillai - Checking, are you also clearing the cq:distribute property and saving session?

Avatar

Level 3

Hi @Shubham_borole ,
I realized yesterday that we need to again set the property to false or delete it so that it can work again next time when I make it true.
Is this the proper way?
Shouldn't it be like you make it true and it will reverse replicate every time unless you make it false again?

Anyways, Thanks for Answering.