Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Replication Queue blocked - Failed to register namespace mapping

kbitra1998
Level 2
Level 2

We are facing the namespace issue frequently while activating the assests from author to publisher, we are getting below error

ERROR - publish1useast1 : << error: com.day.cq.replication.ReplicationException: Repository error during node import: Failed to register namespace mapping ns1 -> http://www.gimp.org/xmp/

ERROR - publish1useast1 : << error: com.day.cq.replication.ReplicationException: Repository error during node import: Failed to register namespace mapping ns1_2_ -> http://ns.attribution.com/ads/1.0/

ERROR - publish1useast1 : << error: com.day.cq.replication.ReplicationException: Repository error during node import: Failed to register namespace mapping pdfaProperty -> http://www.aiim.org/pdfa/ns/property#

 

We are temporarily solving this issue by adding the namespaces from CRX/DE explorer and add namespace manually.

 

As we cannot predict the missing namespaces as they are differed from asset to asset as per author content, we are looking for a permanent solution how to avoid this blocker for upcoming new namespace issues.

 

We have been facing this issue after upgrading the AEM 6.5.0 to SP 5, could you please help us to resolve this issue or provide the more details to address this issue.

 

 

1 Accepted Solution
asutosh_jena
Correct answer by
Community Advisor
Community Advisor

On publish instance you will have a replication receiver user which is normally used for replication. Please ensure the correct user and update the permission. It should fix the issue.

http://localhost:4503/etc/replication/agents.publish.html

 

View solution in original post

12 Replies
asutosh_jena
Community Advisor
Community Advisor

Hi @kbitra1998 

 

I have seen this type of issue mostly while replicating the PDF files. To solve this I did provide the admin privilage to the replication user which did resolve the issue as we cannot predict what will be the name space that can throw another error in future.

 

Thanks!

kbitra1998
Level 2
Level 2

Hi @asutosh_jena ,

I have updated the replicate user permissions as below image.

kbitra1998_0-1631084723574.png

 

Now I am facing a new error below

Error while building replication content java.lang.IllegalArgumentException: javax.jcr.NamespaceException: javax.jcr.NamespaceException: Unknown namespace prefix: ns1_2_

asutosh_jena
Community Advisor
Community Advisor

Hi @kbitra1998 

 

Please provide admin access to the user that used for replication. If the user name is "replication-user" then you need to add the user into administrators group and all these issue should be resolved.

 

asutosh_jena_0-1631084888108.png

 

kbitra1998
Level 2
Level 2

Hi @asutosh_jena , provided the admin access to replication user as per the screenshot.

Still I am facing the same error

Error while building replication content java.lang.IllegalArgumentException: javax.jcr.NamespaceException: javax.jcr.NamespaceException: Unknown namespace prefix: ns1_2_

asutosh_jena
Community Advisor
Community Advisor

Please validate the transport user name and ensure the same user has admin access. If it's the correct user then it will definitely work. Please ensure the replication queue is cleared before the fresh replication is started.

kbitra1998
Level 2
Level 2

Hi @asutosh_jena ,

I have attached the screenshot of the Replication settings and also the permission of the user below:-

 

kbitra1998_0-1631085845035.png

 

kbitra1998_1-1631085957018.png

 

 

 

asutosh_jena
Community Advisor
Community Advisor

I see this is only on Author. What about the publish instance? Have you done the same changes on publish instance? It needs to be done on publish as well and the user should be replication receiver I believe. Please check the correct user on publish and adjust the permission.

kbitra1998
Level 2
Level 2

Hi @asutosh_jena ,

 In publish instance, we aren't using any replication user 

kbitra1998_3-1631086490949.png

Shall I update the user to replication receiver?

 

asutosh_jena
Correct answer by
Community Advisor
Community Advisor

On publish instance you will have a replication receiver user which is normally used for replication. Please ensure the correct user and update the permission. It should fix the issue.

http://localhost:4503/etc/replication/agents.publish.html

 

View solution in original post

fanindras
Level 5
Level 5

Hi @kbitra1998 -

 

Please follow the instructions in https://experienceleague.adobe.com/docs/experience-manager-64/deploying/configuring/troubleshoot-rep...

 

Screenshot 2021-09-08 at 1.58.06 PM.png

You only need to make sure the user in your replication agent is present in publish instance and assign repository level permissions to the same user for jcr:namespaceManagement privilege in Publish instance.

 

Thanks,

Fani

kbitra1998
Level 2
Level 2

Hi @fanindras ,

yes, I have done all the steps according to the screenshot, Still I am facing an issue

Error while building replication content java.lang.IllegalArgumentException: javax.jcr.NamespaceException: javax.jcr.NamespaceException: Unknown namespace prefix: ns1_2_

 

fanindras
Level 5
Level 5

Hi @kbitra1998  - 

Just to debug and rule out the permissions issue, try updating replication agent with admin user and replicate the content. It should be successful. You can revert the user, after performing this test.

 

Thanks,

Fani