Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.
SOLVED

Replication between author and publish doesn't delete nodes.

Avatar

Level 1

I'm new to CQ so I've been doing a lot of reading and I can't find what I thought I read somewhere.  

I set up replication between author and publish.  When I delete content in author and activate the directory the content doesn't get deleted in the publishing instance.

Is this normal behavior?  

I was sure that I read somewhere activation/replication would make the two look identical.

 

Any input is appreciated.

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

OOTB a delete should also trigger deactivation. That means if a resource is deleted on author, it will trigger unpublish event, which will delete from publish.

This delete from publish would be successful, only if the Replication queue is set up and not blocked.

 

A better approach is to deactivate first. Validate publish and then delete from author


Aanchal Sikka

View solution in original post

3 Replies

Avatar

Level 8

Yes, pages that you delete on the author instance should also be removed on the publish instance.

Are you using the default replication agents and configs?

scott

Avatar

Level 1

It sounds like replication may be set up incorrectly. When you add a new page does it replicate correctly?

Avatar

Correct answer by
Community Advisor

OOTB a delete should also trigger deactivation. That means if a resource is deleted on author, it will trigger unpublish event, which will delete from publish.

This delete from publish would be successful, only if the Replication queue is set up and not blocked.

 

A better approach is to deactivate first. Validate publish and then delete from author


Aanchal Sikka