Expand my Community achievements bar.

rep:policy node not getting activated

Avatar

Level 3

We are working on AEM 6.1 We have a custom job that will get activate a site once it got created in author. On site creation, in our custome job, we are creating some user groups and providing access to that site only for them and then will activate the site. But our replication queue is getting stuck as rep:policy node us not getting activated.

Below is the error we are getting.

07.06.2016 14:12:18 - ERROR - publish1 : Replication (ACTIVATE) of /content/groups/mysite/rep:policy not successful. Conversation follows
07.06.2016 14:12:18 - ERROR - publish1 : ------------------------------------------------
07.06.2016 14:12:18 - ERROR - publish1 : Sending message to 10.43.32.4:8443
07.06.2016 14:12:18 - ERROR - publish1 : >> POST /bin/receive HTTP/1.0
07.06.2016 14:12:18 - ERROR - publish1 : >> Action: Activate
07.06.2016 14:12:18 - ERROR - publish1 : >> Path: /content/groups/mysite/rep%3apolicy
07.06.2016 14:12:18 - ERROR - publish1 : >> Handle: /content/groups/mysite/rep%3apolicy
07.06.2016 14:12:18 - ERROR - publish1 : >> Referer: about:blank
07.06.2016 14:12:18 - ERROR - publish1 : >> ...spooling 646 bytes...
07.06.2016 14:12:18 - ERROR - publish1 : --
07.06.2016 14:12:18 - ERROR - publish1 : << HTTP/1.1 400 Bad Request
07.06.2016 14:12:18 - ERROR - publish1 : << Date: Tue, 07 Jun 2016 18:12:18 GMT
07.06.2016 14:12:18 - ERROR - publish1 : << X-Content-Type-Options: nosniff
07.06.2016 14:12:18 - ERROR - publish1 : << Content-Type: text/plain; charset=UTF-8
07.06.2016 14:12:18 - ERROR - publish1 : << Content-Length: 37
07.06.2016 14:12:18 - ERROR - publish1 : << Server: Jetty(9.2.9.v20150224)
07.06.2016 14:12:18 - ERROR - publish1 : << X-Powered-By: Jetty(9.2.9.v20150224)
07.06.2016 14:12:18 - ERROR - publish1 : << 
07.06.2016 14:12:18 - ERROR - publish1 : << error: java.lang.NullPointerException
07.06.2016 14:12:18 - ERROR - publish1 : Message sent.

Any idea how this can be resolved?

2 Replies

Avatar

Level 2

Hi,

I am also facing the same issue. Did anyone know how to resolve this. At page level we have cugs and we see this failure message when we activate the page. 

06.09.2016 15:34:09 - INFO - publish : Replication (ACTIVATE) of /content/iss/partnernet-lexmark-com/en_us/products/jcr:content/par/grid/column0/par/cugparsys_3/rep:policy not successful.
06.09.2016 15:35:09 - INFO - publish : Create new HttpClient for Default Agent
06.09.2016 15:35:09 - INFO - publish : * Auth User: admin
06.09.2016 15:35:09 - INFO - publish : * HTTP Version: 1.1
06.09.2016 15:35:09 - INFO - publish : Sending POST request to http://localhost:4503/bin/receive?sling:authRequestLogin=1
06.09.2016 15:35:09 - INFO - publish : sent. Response: 400 Bad Request
06.09.2016 15:35:09 - ERROR - publish : Replication (ACTIVATE) of /content/iss/partnernet-lexmark-com/en_us/products/jcr:content/par/grid/column0/par/cugparsys_3/rep:policy not successful. Conversation follows
06.09.2016 15:35:09 - ERROR - publish : ------------------------------------------------
06.09.2016 15:35:09 - ERROR - publish : Sending message to localhost:4503
06.09.2016 15:35:09 - ERROR - publish : >> POST /bin/receive HTTP/1.0
06.09.2016 15:35:09 - ERROR - publish : >> Action: Activate
06.09.2016 15:35:09 - ERROR - publish : >> Path: /content/iss/partnernet-lexmark-com/en_us/products/jcr%3acontent/par/grid/column0/par/cugparsys_3/rep%3apolicy
06.09.2016 15:35:09 - ERROR - publish : >> Handle: /content/iss/partnernet-lexmark-com/en_us/products/jcr%3acontent/par/grid/column0/par/cugparsys_3/rep%3apolicy
06.09.2016 15:35:09 - ERROR - publish : >> Referer: about:blank
06.09.2016 15:35:09 - ERROR - publish : >> ...spooling 1287 bytes...
06.09.2016 15:35:09 - ERROR - publish : --
06.09.2016 15:35:09 - ERROR - publish : << HTTP/1.1 400 Bad Request
06.09.2016 15:35:09 - ERROR - publish : << Date: Tue, 06 Sep 2016 19:35:09 GMT
06.09.2016 15:35:09 - ERROR - publish : << X-Content-Type-Options: nosniff
06.09.2016 15:35:09 - ERROR - publish : << Set-Cookie: cq-authoring-mode=TOUCH;Path=/;Expires=Tue, 13-Sep-2016 19:35:09 GMT
06.09.2016 15:35:09 - ERROR - publish : << Expires: Thu, 01 Jan 1970 00:00:00 GMT
06.09.2016 15:35:09 - ERROR - publish : << Content-Type: text/plain; charset=UTF-8
06.09.2016 15:35:09 - ERROR - publish : << Content-Length: 37
06.09.2016 15:35:09 - ERROR - publish : << Server: Jetty(9.2.9.v20150224)
06.09.2016 15:35:09 - ERROR - publish : << X-Powered-By: Jetty(9.2.9.v20150224)
06.09.2016 15:35:09 - ERROR - publish : << 
06.09.2016 15:35:09 - ERROR - publish : << error: java.lang.NullPointerException
06.09.2016 15:35:09 - ERROR - publish : Message sent.
06.09.2016 15:35:09 - ERROR - publish : ------------------------------------------------
06.09.2016 15:35:09 - INFO - publish : Replication (ACTIVATE) of /content/iss/partnernet-lexmark-com/en_us/products/jcr:content/par/grid/column0/par/cugparsys_3/rep:policy not successful.

Any thoughts would be appreciated.

Avatar

Employee Advisor

Please check the error.log on the receiving/publish instance. There should be more information about what went wrong.

Jörg

page footer
This widget could not be displayed.