Highlighted

References of the pages are not show

sharsha5545

20-05-2019

Hi Team,

I am facing issue to view the references of the page 'localhost:4502/sites.html/content'. I have edited the components in a page and author some unpublished images. Now when i try to publish page from the left corner menu option, i can see the references listed that needs to be published. Screenshot 2019-05-20 at 6.31.37 PM.png

But when i select my page and  try to see the references of that page in references dropdown present in sites.html. Then it shows nothing except 0 value for every it tried authoring.

Screenshot 2019-05-20 at 6.36.35 PM.png

Can you let me know how to get the references?

Thanks,

Harsha.

Replies

Highlighted

jbrar

Employee

20-05-2019

I believe you need to use the Reference Component under the General Category in order for references to show up in the left pane.

Screen Shot 2019-05-20 at 5.09.43 PM.png

I tested this on my local instance and using the reference component works as expected.

Highlighted

sharsha5545

21-05-2019

Hi Jaideep,  instead of using reference component. Does the reference rail show the referenced links in the page for eg. any page links that given in the component dialog

Highlighted

jbrar

Employee

21-05-2019

Yes, the reference rail will show the links you reference within the components. The example below from my local instance :

- Opened a page named "/content/we-retail/us/en/experience/arctic-surfing-in-lofoten.html"

- Added an RTE component to the page and then a link to "/content/we-retail/ca/en/men.html" within the component.

- Go to references for "/content/we-retail/ca/en/men.html" and notice that incoming links will have the reference for "/content/we-retail/us/en/experience/arctic-surfing-in-lofoten.html"

Screen Shot 2019-05-21 at 8.48.22 AM.png

Highlighted

sharsha5545

21-05-2019

Yes, Jaideep I am sorry i did't mention the version I am using AEM 6.3. Do we have any solution for that. I even checked in 6.4 it doesn't appear there also.