Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Problem with encoding in email subject - 6.3 or 6.4

Avatar

Avatar
Ignite 1
Level 1
radhag85825056
Level 1

Like

1 like

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back
Boost 1
View profile

Avatar
Ignite 1
Level 1
radhag85825056
Level 1

Like

1 like

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back
Boost 1
View profile
radhag85825056
Level 1

26-08-2019

Hi Everyone,

I have a problem with subject encoding. My email subject contains these chinese characters - 意向客户-参展预订-CN官网渠道 (emailSubject is the property name in the JCR to store this value) but when a User receives an email, these characters are shown like this - 意向客户-参展预订-CNå®˜ç½‘æ¸ é“

I have checked in the Publisher Logs interacting with SMTP Server and I'm getting this in the logs:

Subject: =?UTF-8?B?w6bChMKPw6XCkMKRw6XCrsKiw6bCiMK3LcOlwo/CgsOlwrHClcOp?=

=?UTF-8?B?wqLChMOowq7Coi1DTsOlwq7CmMOnwr3CkcOmwrjCoMOpwoHCkw==?=

MIME-Version: 1.0

Content-Type: text/plain; charset=UTF-8

Content-Transfer-Encoding: quoted-printable

Template is defined as:

From: noreply@testmail.co.uk

Subject: ${emailSubject}

Author name: ${authorName}

${formData}

All other custom fields (like firstName, lastName etc) looks fine and enoding/decoding also looks Ok for these fields:

title: =E5=A4=AB=E4=BA=BA

salutation: =E5=8D=9A=E5=A3=AB=E6=95=99=E6=8E=88

firstname: =E9=9C=80=E8=A6=81=E5=A1=AB=E5=86=99=E7=A7=B0=E8=B0=93

surname: =E9=9C=80=E8=A6=81=E5=A1=AB=E5=86=99=E7=A7=B0=E8=B0=93

Seems to be encoding issue for the Subject Field.

Has anyone encountered this issue while using EmailService.sendEmail(var1, var2, var3)?

Replies

Avatar

Avatar
Establish
MVP
Gaurav-Behl
MVP

Likes

248 likes

Total Posts

1,147 posts

Correct Reply

283 solutions
Top badges earned
Establish
Give back 300
Give Back 50
Give Back 5
Give Back 3
View profile

Avatar
Establish
MVP
Gaurav-Behl
MVP

Likes

248 likes

Total Posts

1,147 posts

Correct Reply

283 solutions
Top badges earned
Establish
Give back 300
Give Back 50
Give Back 5
Give Back 3
View profile
Gaurav-Behl
MVP

27-08-2019

Check if this helps In Mail question mark is coming in place of special characters

Did you try to reproduce this issue with an updated version of acs commons?

Avatar

Avatar
Ignite 1
Level 1
radhag85825056
Level 1

Like

1 like

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back
Boost 1
View profile

Avatar
Ignite 1
Level 1
radhag85825056
Level 1

Like

1 like

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back
Boost 1
View profile
radhag85825056
Level 1

27-08-2019

Yes, I am using ACS Commons version 3.19.0.

Also, I tried to put the hard-coded Chinese string in the mail (abc.txt) directly and this is still not working.

Avatar

Avatar
Validate 1
Level 3
tahir1601
Level 3

Likes

21 likes

Total Posts

41 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Give Back 5
Give Back 3
Give Back
Boost 5
View profile

Avatar
Validate 1
Level 3
tahir1601
Level 3

Likes

21 likes

Total Posts

41 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Give Back 5
Give Back 3
Give Back
Boost 5
View profile
tahir1601
Level 3

25-02-2020

I am also facing the same issue while using day cq mail service. Subject line with French characters are getting encoded and displayed. Can you please help

 

@arunk @arunpatidar26 @smacdonald2008