Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

pdf viewer not working in the webserver url alone

Gowtham_ford
Level 1
Level 1

I can see the pdf viewer in publish servers but in the varnish/webserver url the pdf viewer is not loaded. The sdk or the component div is not created, i am not seeing any errors in log or console.

 

5 Replies
Vijayalakshmi_S
Community Advisor
Community Advisor

Hi @Gowtham_ford,

If you are using core PDFViewer component for the same, can you confirm you are using the clientId of the webserver URL ?

Gowtham_ford
Level 1
Level 1

Hi @Vijayalakshmi_S ,

 

Yes am using the client id for webserver url only. Actually the component itself is not showing like the div itself is not generating.

 

<div class="pdfviewer section"></div> - This the only thing i could see the in the webserver url.

Vijayalakshmi_S
Community Advisor
Community Advisor

Hi @Gowtham_ford,

Yes. I had a chance to try when there was a similar issue as yours in this thread - https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager/issues-with-pdf-viewer/qaq...

When I don't provide valid client Id, it will be blank.

 

You would have done custom implementation to pick client Id for each run mode and to handle webserver URL. 

Cross check the same once and above shared community thread or share your high level implementation detail to handle clientId for debugging further. 

Gowtham_ford
Level 1
Level 1

Hi @Vijayalakshmi_S ,

 

Got the issue, it seems like the config folder is not accessible by anonymous user. After giving permission for anonymous user to conf folder it is working.

 

Need to know is it okay with the permission setup?

Vijayalakshmi_S
Community Advisor
Community Advisor
read permission on /conf folder in AEM instance level is fine. At dispatcher, deny access to /conf path