Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

OSGI Configuration "Default Parameter Encoding" UTF-8

Avatar

Avatar
Validate 1
Level 1
ronald_ploeger
Level 1

Like

1 like

Total Posts

12 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 1
ronald_ploeger
Level 1

Like

1 like

Total Posts

12 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 1
Affirm 1
View profile
ronald_ploeger
Level 1

15-10-2015

Hi,

I set the OSGI Configuration "Default Parameter Encoding" in "Apache Sling Request Parameter Handling" to UTF-8 but query string request parameters are still decoded as ISO-Latin-1.

When I set the the additional request parameter "_charset_=UTF-8" it works.

Is there any reason that the OSGI Configuration "Default Parameter Encoding" is not sufficient?

Best regards,

Ronald

View Entire Topic

Avatar

Avatar
Validate 10
Level 3
sunitac2231600
Level 3

Likes

4 likes

Total Posts

90 posts

Correct Reply

0 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 10
View profile

Avatar
Validate 10
Level 3
sunitac2231600
Level 3

Likes

4 likes

Total Posts

90 posts

Correct Reply

0 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 10
View profile
sunitac2231600
Level 3

01-11-2016

Hi Ronald,

I have setup the "Default Parameter Encoding" in "Apache Sling Request Parameter Handling" to UTF-8 , as shown in below screenshot.

But the encoding is not working.

Could you please tell me how to change this one ?