Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

OOTB Console errors in 6.5 Upgraded Page

Avatar

Level 4

Hi Team,

 

We are getting below errors in few of our pages but pages are functioning properly. This errors are coming for 6.5 upgraded instances only in few pages. rest of the pages are looking neat in console.

As it is OOTB errors, not sure what to do.

akhilr48142671_0-1649910485875.png

 

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

It might be clientlib dependency is causing this issue.

 

We can refer below steps to troubleshoot the issue -

1. As you are facing the said issue with few pages, were those page created with same template?

   if yes, then please check page rendering component via sling:resourceType property at jcr:content node  

   of page.

   Check what are the clientlibaries are getting used , dependency client libraries like below one -

DEBAL_DAS_0-1649929455442.png

 

and compare with dependency client libraries associated with pages where you aren't seeing this issue.

 

2. Regarding babel-polyfill  issue please refer below links -

 

https://stackoverflow.com/questions/53287691/uncaught-error-only-one-instance-of-babel-polyfill-is-a...

https://github.com/babel/babel-loader/issues/401

https://stackoverflow.com/questions/43902416/only-one-instance-of-babel-polyfill-is-allowed-error

 

View solution in original post

3 Replies

Avatar

Community Advisor

Hi @akhilr48142671 ,

 

Looks like babel-polyfill has been included multiple times (third party libraries?), can you check your web-config. Just check below thread-

 

https://lifesaver.codes/answer/babel-polyfill-error-error-only-one-instance-of-babel-polyfill-is-all... 

Avatar

Correct answer by
Community Advisor

It might be clientlib dependency is causing this issue.

 

We can refer below steps to troubleshoot the issue -

1. As you are facing the said issue with few pages, were those page created with same template?

   if yes, then please check page rendering component via sling:resourceType property at jcr:content node  

   of page.

   Check what are the clientlibaries are getting used , dependency client libraries like below one -

DEBAL_DAS_0-1649929455442.png

 

and compare with dependency client libraries associated with pages where you aren't seeing this issue.

 

2. Regarding babel-polyfill  issue please refer below links -

 

https://stackoverflow.com/questions/53287691/uncaught-error-only-one-instance-of-babel-polyfill-is-a...

https://github.com/babel/babel-loader/issues/401

https://stackoverflow.com/questions/43902416/only-one-instance-of-babel-polyfill-is-allowed-error

 

Avatar

Level 4

The inclusion of coralui3 fixed the issue. Thank you all