Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

On uploading an image/asset to DAM, renditions/original thumbnail view is not showing in AEM 6.4

Avatar

Avatar
Validate 1
Level 1
VenkateshDhulip
Level 1

Likes

0 likes

Total Posts

7 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
VenkateshDhulip
Level 1

Likes

0 likes

Total Posts

7 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
VenkateshDhulip
Level 1

05-04-2019

Hi All,

Recently we have migrated from AEM 6.2 to 6.4,when we upload an image/asset to DAM, renditions/original thumbnail view is not showing up instead it is showing up ".thumb.319.319.png" thumbnail view.

Is there any way to use renditions/original for DAM assets without overlay/overriding OOTB code.

We are using below versions in POM.xml but when i check in felix console, cq-dam-commons version is 5.11.182 and cq-dam-api version is 5.11.70

com.day.cq.dam.cq-dam-commons - 5.6.8 version

com.day.cq.dam.cq-dam-api - 5.6.6 version

Replies

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

07-04-2019

How did you upload the asset - using a workflow, using the UI?

Avatar

Avatar
Validate 1
Level 1
VenkateshDhulip
Level 1

Likes

0 likes

Total Posts

7 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
VenkateshDhulip
Level 1

Likes

0 likes

Total Posts

7 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
VenkateshDhulip
Level 1

07-04-2019

Asset has been uploaded manually into the DAM using Upload process. After uploading the asset to DAM some default  renditions are getting creating but our issue is not about renditions.

Our Exact Issue: Why in AEM 6.4 for thumbnail view of image it is using 319*319 rendition path instead of renditions/original path which is working fine AEM 6.2. Is there any kind of service packs we have to install?

When we check in DOM, i see that image path of thumbnail view in card view/list view/column view is something like below

/content/dam/project/testimage.jpg.thumb.319.319.png

Expected: /content/dam/project/testimage.jpg/_jcr_content/renditions/original (Which is as per AEM 6.2)

Avatar

Avatar
Validate 10
MVP
kunal23
MVP

Likes

166 likes

Total Posts

565 posts

Correct Reply

172 solutions
Top badges earned
Validate 10
Validate 1
Ignite 3
Ignite 1
Give Back 50
View profile

Avatar
Validate 10
MVP
kunal23
MVP

Likes

166 likes

Total Posts

565 posts

Correct Reply

172 solutions
Top badges earned
Validate 10
Validate 1
Ignite 3
Ignite 1
Give Back 50
View profile
kunal23
MVP

07-04-2019

If you are asking about the Asset Card view display in the Touch UI then yes it should render a thumbnail of 319X319 size. Why do you would like to use original image for card view display ? Isn't that going to be a performance issue. If in 6.2 it was rendering original images then it should be a bug because it does not make sense to display original images for card view.

Avatar

Avatar
Validate 1
Level 7
Hemant_arora
Level 7

Likes

92 likes

Total Posts

290 posts

Correct Reply

54 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 50
View profile

Avatar
Validate 1
Level 7
Hemant_arora
Level 7

Likes

92 likes

Total Posts

290 posts

Correct Reply

54 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 50
View profile
Hemant_arora
Level 7

08-04-2019

On 6.2 also you should see a rendition only instead of the original image. something like 1280.1280 one or the one whose width is nearer to given width.  I just figured out that as soon as you upload the image on 6.2 , for a moment while the image is being processed, it shows you the path of original because its still creating different renditions. Once the renditions are created, and if we reload the page again, it displays the 1280 rendition.

or while uploading image to 6.2, you must have disabled the update asset workflow launcher.

See the comparison in the getThumbnailUrl method in 6.2 and 6.4

/libs/dam/gui/coral/components/admin/contentrenderer/base/base.jsp

You need not do any changes or overlaying. And moreover why do you want to show the original image when the rendition is available ?

Also please mention if the images in your 6.2 instance had renditions or not?