Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

On clicking the "Drag your component here", 'Insert Component' or '+' is selected by default.

ayushidimri
Level 1
Level 1
I am using AEM 6.5. When I copy a component/components using command+c and try to paste it using command+v, it requires clicking twice on 'Drag your component here'. I believe this is happening because whenever I click on 'Drag your component here' , by default '+' is selected. This is causing issues fro the content authors to paste the component. Can someone help with what config changes should be done to the toolbar so that '+' is not selected by default or how can I prevent double click to paste the component using command+v.
4 Replies
Arun_Patidar
Community Advisor
Community Advisor

In the toolbar, there are dedicated buttons to copy and paste. Why are you not using those?

ayushidimri
Level 1
Level 1

The content authors want to use the keyboard especially while copying multiple components. Another thing they I noticed is, that it was working fine for AEM version 6.5.1.0. The recent patch for AEM version 6.5.5 us causing this. Thanks!

Varun_Shakya
Community Advisor
Community Advisor

It works fine for me I am also using AEM 6.5 . If you are facing this problem that might because of issue in your template or in your component. 

Check in We retail project in your local instance. Do you face the similar issue there?

Or as Arun suggested use the dedicated buttons to copy and paste.

ayushidimri
Level 1
Level 1

Hi Varun, I works fine for 6.5.1.0. After applying the patch for 6.5.5 it works like that. I think it's an upgrade or a feature added. I am looking for a way to override the behaviour because the content authors want it to be like that. Thanks!