Highlighted

Not able to verify Personalization using contexthub setup - AEM 6.4

Avatar

Avatar

ChandraSGupta

Avatar

ChandraSGupta

ChandraSGupta

26-11-2018

Steps Performed - ( AEM  6.4 )

1) Navigated to Audience Page  and created a Context hub segment ( but i only see option with Default & We.Retail), so used We.Retail and created contexthub segment.

2) Setup a custom segment here for male/female profile

3) Created a brand/activity and followed normal steps to complete it.

But when I apply this to my site and verify personalization in preview mode, it don't work whereas same activity works fine with We.Retail.

is it because ContextHub segment is created with in scope of we-retail ?

What are the steps to get ContextHub Segment created for my site? Do I need to configure in conf, please suggest way for this.

appreciate your help, many thanks!

Replies

Highlighted

Avatar

Avatar

kautuk_sahni

Community Manager

Total Posts

5.6K

Likes

961

Correct Answer

1.1K

Avatar

kautuk_sahni

Community Manager

Total Posts

5.6K

Likes

961

Correct Answer

1.1K
kautuk_sahni
Community Manager

29-11-2018

Highlighted

Avatar

Avatar

Abhishek_Dweved

Employee

Avatar

Abhishek_Dweved

Employee

Abhishek_Dweved
Employee

29-11-2018

You need to create new configuration and apply the configuration on your project.

1. Go to AEM > Tools > Configuration Browser

2. Create  > Select ContextHub Segments

1633212_pastedImage_3.png

This will fix your first issue - In Audience section , you should be able to see your own project name as well.

To fix the second issue , Go to properties of your project

Properties > Advance Tab >  Configuration > Cloud Configuration > Add your configuration folder path

1633211_pastedImage_2.png

Highlighted

Avatar

Avatar

ChandraSGupta

Avatar

ChandraSGupta

ChandraSGupta

24-12-2018

Thanks Abhishek, It helped.

Also I needed to map the contexthub configurations too @ Site > Properties >Personalization