Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Not able to verify Personalization using contexthub setup - AEM 6.4

Avatar

Avatar
Validate 1
Level 1
ChandraSGupta
Level 1

Like

1 like

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 1
ChandraSGupta
Level 1

Like

1 like

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
ChandraSGupta
Level 1

26-11-2018

Steps Performed - ( AEM  6.4 )

1) Navigated to Audience Page  and created a Context hub segment ( but i only see option with Default & We.Retail), so used We.Retail and created contexthub segment.

2) Setup a custom segment here for male/female profile

3) Created a brand/activity and followed normal steps to complete it.

But when I apply this to my site and verify personalization in preview mode, it don't work whereas same activity works fine with We.Retail.

is it because ContextHub segment is created with in scope of we-retail ?

What are the steps to get ContextHub Segment created for my site? Do I need to configure in conf, please suggest way for this.

appreciate your help, many thanks!

Replies

Avatar

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,130 likes

Total Posts

6,161 posts

Correct Reply

1,144 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,130 likes

Total Posts

6,161 posts

Correct Reply

1,144 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile
kautuk_sahni
Community Manager

29-11-2018

Avatar

Avatar
Give Back 5
Employee
Abhishek_Dweved
Employee

Likes

14 likes

Total Posts

37 posts

Correct Reply

11 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back
Boost 5
Boost 3
View profile

Avatar
Give Back 5
Employee
Abhishek_Dweved
Employee

Likes

14 likes

Total Posts

37 posts

Correct Reply

11 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back
Boost 5
Boost 3
View profile
Abhishek_Dweved
Employee

29-11-2018

You need to create new configuration and apply the configuration on your project.

1. Go to AEM > Tools > Configuration Browser

2. Create  > Select ContextHub Segments

1633212_pastedImage_3.png

This will fix your first issue - In Audience section , you should be able to see your own project name as well.

To fix the second issue , Go to properties of your project

Properties > Advance Tab >  Configuration > Cloud Configuration > Add your configuration folder path

1633211_pastedImage_2.png

Avatar

Avatar
Validate 1
Level 1
ChandraSGupta
Level 1

Like

1 like

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 1
ChandraSGupta
Level 1

Like

1 like

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
ChandraSGupta
Level 1

24-12-2018

Thanks Abhishek, It helped.

Also I needed to map the contexthub configurations too @ Site > Properties >Personalization