Not able to fix these dependency issues

Avatar

Avatar
Give Back
Level 1
Heena06
Level 1

Likes

0 likes

Total Posts

40 posts

Correct reply

0 solutions
Top badges earned
Give Back
Ignite 1
Validate 1
Applaud 5
View profile

Avatar
Give Back
Level 1
Heena06
Level 1

Likes

0 likes

Total Posts

40 posts

Correct reply

0 solutions
Top badges earned
Give Back
Ignite 1
Validate 1
Applaud 5
View profile
Heena06
Level 1

07-10-2020

Hi,

 

I am not able to fix these dependency issues, I checked it in http://localhost:4502/system/console/depfinder and used the dependency in my project's Parent pom.xml, Can anyone suggest is it the correct way or I need to add the dependencies in each folder's pom.xml under my project. 

 

Heena06_2-1602102001696.png

 

 

Also, dependencies available are of lesser version. How I can get it updated.

 

Heena06_3-1602102097757.png

 

 

Heena06_0-1602101620693.pngHeena06_1-1602101677322.png

 

Thanks,

Heena

 

Replies

Avatar

Avatar
Establish
MVP
Ravi_Pampana
MVP

Likes

197 likes

Total Posts

243 posts

Correct reply

75 solutions
Top badges earned
Establish
Contributor
Shape 1
Ignite 5
Ignite 3
View profile

Avatar
Establish
MVP
Ravi_Pampana
MVP

Likes

197 likes

Total Posts

243 posts

Correct reply

75 solutions
Top badges earned
Establish
Contributor
Shape 1
Ignite 5
Ignite 3
View profile
Ravi_Pampana
MVP

07-10-2020

Hi,

 

Can you check uber jar is upto date of the AEM version ? Sometimes we see these issues because of uber jar is having older version

Avatar

Avatar
Boost 5
Level 3
vmadala
Level 3

Likes

21 likes

Total Posts

28 posts

Correct reply

5 solutions
Top badges earned
Boost 5
Establish
Boost 3
Boost 1
Affirm 1
View profile

Avatar
Boost 5
Level 3
vmadala
Level 3

Likes

21 likes

Total Posts

28 posts

Correct reply

5 solutions
Top badges earned
Boost 5
Establish
Boost 3
Boost 1
Affirm 1
View profile
vmadala
Level 3

07-10-2020

Hello Heena,

 

You're correct, I think you need to downgrade your bundle versions in the parent pom.xml file, To update these jars on AEM instances you need to upgrade the AEM version. What version are using now .?

And you're child module also need separate pom.ml files. 

 

 

Thanks,

Venkat.

Avatar

Avatar
Give Back
Level 1
Heena06
Level 1

Likes

0 likes

Total Posts

40 posts

Correct reply

0 solutions
Top badges earned
Give Back
Ignite 1
Validate 1
Applaud 5
View profile

Avatar
Give Back
Level 1
Heena06
Level 1

Likes

0 likes

Total Posts

40 posts

Correct reply

0 solutions
Top badges earned
Give Back
Ignite 1
Validate 1
Applaud 5
View profile
Heena06
Level 1

07-10-2020

Hi @vmadala vmadala I m using AEM 6.4.0 version

Avatar

Avatar
Boost 250
MVP
Nikhil-Kumar
MVP

Likes

251 likes

Total Posts

262 posts

Correct reply

38 solutions
Top badges earned
Boost 250
Validate 1
Ignite 3
Ignite 1
Give Back 5
View profile

Avatar
Boost 250
MVP
Nikhil-Kumar
MVP

Likes

251 likes

Total Posts

262 posts

Correct reply

38 solutions
Top badges earned
Boost 250
Validate 1
Ignite 3
Ignite 1
Give Back 5
View profile
Nikhil-Kumar
MVP

08-10-2020

@Heena06 

 
Which version of AEM are you using ?

If some dependencies are not resolved in your AEM instance then you need deploy those dependencies as bundles.


https://aemsimplifiedbynikhil.wordpress.com/2020/08/23/resolve-dependencies-by-converting-jar-to-bun...


Thanks,
Nikhil