No Proxy For - Not working...AEM 6.1Sp2 w&wo CFP10, Java 8

Avatar

Avatar
Validate 1
Level 3
bobkranson
Level 3

Likes

8 likes

Total Posts

68 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Validate 1
Level 3
bobkranson
Level 3

Likes

8 likes

Total Posts

68 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
bobkranson
Level 3

09-08-2017

While validating the Apache HTTP Components Proxy Configuration I ran into issues excluding hosts.  I am hoping Adobe Staff or others in the community might offer suggestions or advice to solve this concern.

1. Enable HTTP Proxy via system/console/configMgr

2. (Issue 1) Do not 'Edit' the Apache HTTP Component Proxy Configuration, it doesn't accept/work

3. Create a new PID instance of Apache HTTP Component Proxy Configuration

4. Set the Enable HTTP Proxy checkbox on (true)

5. Set your proxy host

6. Set your proxy port

7. Add lines for your internal server 'No Proxy Server'

8. (Issue 2-n) Tried specifying 'No Proxy Server' in multiple ways; none worked

     a. Used dot-domain-dot-com (as specified in description of property)

     b. Tried surrounding with single-quotes, tried surrounding with double quotes

     c. Tried asterisk-dot-domain-dot-com (as described for Java Proxy properties definition)

How to see if (not) work:

1. Create a new logger via system/console/configMgr

2. Use + Logger Configuration

    a. Log Level: Debug

    b. Log File: logs/proxyserver.log

    c. Message pattern: (leave default)

    d. Logger: (specified these after using too broad 'org.apache.http')

          org.apache.http.impl.conn.HttpClientConnectionOperator

          org.apache.http.impl.conn.PoolingHttpClientConnectionManager

          org.apache.http.impl.execchain.MainClientExec

          org.apache.http.impl.execchain.RedirectExec

3. Use var/linkchecker.html to execute HTTPClient calls

4. View logs/proxyserver.log

5. Observe:

    a. org.apache.http.impl.conn.HttpClientConnectionOperator Connecting to <your-proxy-server-specified>/<its-resolved-ip>:<port>

    b. org.apache.http.impl.execchain.MainClientExec Opening connection {tls}->http://your-proxy-server-specified:<port>->https://www.<my-excluded-no-proxy-for-server>.com

I would expect that all my links that are in the No Proxy For domain are not passed through the proxy server.  This is not the case.  I've tested this with AEM 6.1SP2 with and without CFP10.  Additionally I've tested it by adding CQ_JVM_OPTS for proxy configuration.  The CQ_JVM_OPTS proxy options are not picked up either....ie. not immediately interpreted or added to the OSGi component (not a big deal) but it raised the concern (Issue 3) that there is not a different panel/property setting for HTTPS proxy:

# Proxy server configuration

CQ_JVM_OPTS="$CQ_JVM_OPTS -Dhttp.proxyHost=myproxyhost -Dhttp.proxyPort=80 -Dhttps.proxyHost=myhttpsproxyhost -Dhttps.proxyPort=443 -Dhttp.nonProxyHosts='locahost|*.mydomain.com|*.mysimilardomain.com'"

Advice and help appreciated!

Replies

Avatar

Avatar
Validate 1
Level 3
bobkranson
Level 3

Likes

8 likes

Total Posts

68 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Validate 1
Level 3
bobkranson
Level 3

Likes

8 likes

Total Posts

68 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
bobkranson
Level 3

14-08-2017

No reply for 5 days, so do I proceed to a support ticket?

Avatar

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

484 likes

Total Posts

1,049 posts

Correct reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

484 likes

Total Posts

1,049 posts

Correct reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile
Veena_Vikram
MVP

14-08-2017

smacdonald2008kautuksahni​ Any help here ?

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,409 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,409 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

14-08-2017

Yes - we have no community content or docs that could assist you in this use case - please open a ticket.

Avatar

Avatar
Validate 1
Level 3
bobkranson
Level 3

Likes

8 likes

Total Posts

68 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Validate 1
Level 3
bobkranson
Level 3

Likes

8 likes

Total Posts

68 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
bobkranson
Level 3

28-09-2017

This is fixed in CFP11.