Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Maven Build Error - Could not transfer artifact com.day.jcr.vault:content-package-maven-plugin:pom:1.0.2 from/to adobe-public-releases (https://repo.adobe.com/nexus/content/groups/public)

Avatar

Avatar
Springboard
Level 1
gargrohan
Level 1

Likes

0 likes

Total Posts

16 posts

Correct Reply

0 solutions
Top badges earned
Springboard
Establish
Validate 1
Ignite 1
Give Back
View profile

Avatar
Springboard
Level 1
gargrohan
Level 1

Likes

0 likes

Total Posts

16 posts

Correct Reply

0 solutions
Top badges earned
Springboard
Establish
Validate 1
Ignite 1
Give Back
View profile
gargrohan
Level 1

14-08-2020

Hi All,

 

I am trying to build an already existing maven project using mvn clean install -P autoInstallPackage

I am getting the below error:-

 

Downloading from adobe-public-releases: https://repo.adobe.com/nexus/content/groups/public/com/day/jcr/vault/content-package-maven-plugin/1....
[ERROR] [ERROR] Some problems were encountered while processing the POMs:
[ERROR] Unresolveable build extension: Plugin com.day.jcr.vault:content-package-maven-plugin:1.0.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.day.jcr.vault:content-package-maven-plugin:jar:1.0.2 @
[ERROR] Unknown packaging: content-package @ line 35, column 16
[ERROR] Unresolveable build extension: Plugin com.day.jcr.vault:content-package-maven-plugin:1.0.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.day.jcr.vault:content-package-maven-plugin:jar:1.0.2 @
[ERROR] Unknown packaging: content-package @ line 34, column 16
[ERROR] Unresolveable build extension: Plugin com.day.jcr.vault:content-package-maven-plugin:1.0.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.day.jcr.vault:content-package-maven-plugin:jar:1.0.2 @
[ERROR] Unknown packaging: content-package @ line 34, column 16
@
[ERROR] The build could not read 3 projects -> [Help 1]
[ERROR]
[ERROR] The project com.xyz:xyz-redesign.all:1.0-SNAPSHOT (D:\xyz-redesign\xyz-redesign\all\pom.xml) has 2 errors
[ERROR] Unresolveable build extension: Plugin com.day.jcr.vault:content-package-maven-plugin:1.0.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.day.jcr.vault:content-package-maven-plugin:jar:1.0.2: Could not transfer artifact com.day.jcr.vault:content-package-maven-plugin:pom:1.0.2 from/to adobe-public-releases (https://repo.adobe.com/nexus/content/groups/public  ) : Transfer failed for https://repo.adobe.com/nexus/content/groups/public/com/day/jcr/vault/content-package-maven-plugin/1....: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target -> [Help 2]
[ERROR] Unknown packaging: content-package @ line 35, column 16
[ERROR]
[ERROR] The project com.xyz:xyz-redesign.ui.apps:1.0-SNAPSHOT (D:\xyz-redesign\xyz-redesign\ui.apps\pom.xml) has 2 errors
[ERROR] Unresolveable build extension: Plugin com.day.jcr.vault:content-package-maven-plugin:1.0.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.day.jcr.vault:content-package-maven-plugin:jar:1.0.2: Could not transfer artifact com.day.jcr.vault:content-package-maven-plugin:pom:1.0.2 from/to adobe-public-releases (https://repo.adobe.com/nexus/content/groups/public) : Transfer failed for https://repo.adobe.com/nexus/content/groups/public/com/day/jcr/vault/content-package-maven-plugin/1....: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target -> [Help 2]
[ERROR] Unknown packaging: content-package @ line 34, column 16
[ERROR]
[ERROR] The project com.xyz:xyz-redesign.ui.content:1.0-SNAPSHOT (D:\xyz-redesign\xyz-redesign\ui.content\pom.xml) has 2 errors
[ERROR] Unresolveable build extension: Plugin com.day.jcr.vault:content-package-maven-plugin:1.0.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.day.jcr.vault:content-package-maven-plugin:jar:1.0.2: Could not transfer artifact com.day.jcr.vault:content-package-maven-plugin:pom:1.0.2 from/to adobe-public-releases (https://repo.adobe.com/nexus/content/groups/public) :Transfer failed for https://repo.adobe.com/nexus/content/groups/public/com/day/jcr/vault/content-package-maven-plugin/1....: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target -> [Help 2]
[ERROR] Unknown packaging: content-package @ line 34, column 16

 

I am able to connect to URL https://repo.adobe.com/nexus/content/groups/public/com/day/jcr/vault/content-package-maven-plugin/1.... using my browser and my settings.xml file for m2 has https based URL. <url>https://repo.adobe.com/nexus/content/groups/public</url>

 

Could you please let me know how to resolve this issue ?

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Ignite 1
MVP
Ankur_Khare
MVP

Likes

159 likes

Total Posts

370 posts

Correct Reply

58 solutions
Top badges earned
Ignite 1
Validate 10
Validate 1
Give Back 50
Give Back 5
View profile

Avatar
Ignite 1
MVP
Ankur_Khare
MVP

Likes

159 likes

Total Posts

370 posts

Correct Reply

58 solutions
Top badges earned
Ignite 1
Validate 10
Validate 1
Give Back 50
Give Back 5
View profile
Ankur_Khare
MVP

14-08-2020

try this command-

 

mvn clean install -P autoInstallPackage -Dmaven.wagon.http.ssl.insecure=true -Dmaven.wagon.http.ssl.allowall=true

Answers (2)

Answers (2)

Avatar

Avatar
Boost 250
MVP
Nikhil-Kumar
MVP

Likes

251 likes

Total Posts

262 posts

Correct Reply

38 solutions
Top badges earned
Boost 250
Validate 1
Ignite 3
Ignite 1
Give Back 5
View profile

Avatar
Boost 250
MVP
Nikhil-Kumar
MVP

Likes

251 likes

Total Posts

262 posts

Correct Reply

38 solutions
Top badges earned
Boost 250
Validate 1
Ignite 3
Ignite 1
Give Back 5
View profile
Nikhil-Kumar
MVP

15-08-2020

Hey,

Try using the mvn -PautoInstallPackage -Padobe-public clean install
If issue still exists you try updating your settings/xml in .m2 folder.

I have the updated settings.xml which worked for me, you get it on my post settings.xml
I
t contains Adobe Public added to it.
It worked for me!!!

Avatar

Avatar
Give Back 10
MVP
Varun_Shakya
MVP

Likes

124 likes

Total Posts

97 posts

Correct Reply

24 solutions
Top badges earned
Give Back 10
Ignite 3
Ignite 1
Give Back 5
Give Back 3
View profile

Avatar
Give Back 10
MVP
Varun_Shakya
MVP

Likes

124 likes

Total Posts

97 posts

Correct Reply

24 solutions
Top badges earned
Give Back 10
Ignite 3
Ignite 1
Give Back 5
Give Back 3
View profile
Varun_Shakya
MVP

14-08-2020