Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events
SOLVED

Maven Build Error - Could not transfer artifact com.day.jcr.vault:content-package-maven-plugin:pom:1.0.2 from/to adobe-public-releases (https://repo.adobe.com/nexus/content/groups/public)

Avatar

Level 3

Hi All,

 

I am trying to build an already existing maven project using mvn clean install -P autoInstallPackage

I am getting the below error:-

 

Downloading from adobe-public-releases: https://repo.adobe.com/nexus/content/groups/public/com/day/jcr/vault/content-package-maven-plugin/1....
[ERROR] [ERROR] Some problems were encountered while processing the POMs:
[ERROR] Unresolveable build extension: Plugin com.day.jcr.vault:content-package-maven-plugin:1.0.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.day.jcr.vault:content-package-maven-plugin:jar:1.0.2 @
[ERROR] Unknown packaging: content-package @ line 35, column 16
[ERROR] Unresolveable build extension: Plugin com.day.jcr.vault:content-package-maven-plugin:1.0.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.day.jcr.vault:content-package-maven-plugin:jar:1.0.2 @
[ERROR] Unknown packaging: content-package @ line 34, column 16
[ERROR] Unresolveable build extension: Plugin com.day.jcr.vault:content-package-maven-plugin:1.0.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.day.jcr.vault:content-package-maven-plugin:jar:1.0.2 @
[ERROR] Unknown packaging: content-package @ line 34, column 16
@
[ERROR] The build could not read 3 projects -> [Help 1]
[ERROR]
[ERROR] The project com.xyz:xyz-redesign.all:1.0-SNAPSHOT (D:\xyz-redesign\xyz-redesign\all\pom.xml) has 2 errors
[ERROR] Unresolveable build extension: Plugin com.day.jcr.vault:content-package-maven-plugin:1.0.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.day.jcr.vault:content-package-maven-plugin:jar:1.0.2: Could not transfer artifact com.day.jcr.vault:content-package-maven-plugin:pom:1.0.2 from/to adobe-public-releases (https://repo.adobe.com/nexus/content/groups/public  ) : Transfer failed for https://repo.adobe.com/nexus/content/groups/public/com/day/jcr/vault/content-package-maven-plugin/1....: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target -> [Help 2]
[ERROR] Unknown packaging: content-package @ line 35, column 16
[ERROR]
[ERROR] The project com.xyz:xyz-redesign.ui.apps:1.0-SNAPSHOT (D:\xyz-redesign\xyz-redesign\ui.apps\pom.xml) has 2 errors
[ERROR] Unresolveable build extension: Plugin com.day.jcr.vault:content-package-maven-plugin:1.0.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.day.jcr.vault:content-package-maven-plugin:jar:1.0.2: Could not transfer artifact com.day.jcr.vault:content-package-maven-plugin:pom:1.0.2 from/to adobe-public-releases (https://repo.adobe.com/nexus/content/groups/public) : Transfer failed for https://repo.adobe.com/nexus/content/groups/public/com/day/jcr/vault/content-package-maven-plugin/1....: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target -> [Help 2]
[ERROR] Unknown packaging: content-package @ line 34, column 16
[ERROR]
[ERROR] The project com.xyz:xyz-redesign.ui.content:1.0-SNAPSHOT (D:\xyz-redesign\xyz-redesign\ui.content\pom.xml) has 2 errors
[ERROR] Unresolveable build extension: Plugin com.day.jcr.vault:content-package-maven-plugin:1.0.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.day.jcr.vault:content-package-maven-plugin:jar:1.0.2: Could not transfer artifact com.day.jcr.vault:content-package-maven-plugin:pom:1.0.2 from/to adobe-public-releases (https://repo.adobe.com/nexus/content/groups/public) :Transfer failed for https://repo.adobe.com/nexus/content/groups/public/com/day/jcr/vault/content-package-maven-plugin/1....: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target -> [Help 2]
[ERROR] Unknown packaging: content-package @ line 34, column 16

 

I am able to connect to URL https://repo.adobe.com/nexus/content/groups/public/com/day/jcr/vault/content-package-maven-plugin/1.... using my browser and my settings.xml file for m2 has https based URL. <url>https://repo.adobe.com/nexus/content/groups/public</url>

 

Could you please let me know how to resolve this issue ?

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

try this command-

 

mvn clean install -P autoInstallPackage -Dmaven.wagon.http.ssl.insecure=true -Dmaven.wagon.http.ssl.allowall=true

View solution in original post

7 Replies

Avatar

Correct answer by
Community Advisor

try this command-

 

mvn clean install -P autoInstallPackage -Dmaven.wagon.http.ssl.insecure=true -Dmaven.wagon.http.ssl.allowall=true

Avatar

Level 3

Thank You @Ankur_Khare ! This works correctly.

Upon checking the argument parameters I see maven.wagon.http.ssl.insecure = true relaxes the check of public key certificates.

I had installed the certificate via keytool -import for content-package-plugin. Then taking new built gave below error :-

[ERROR] Failed to execute goal on project xyz-redesign.core: Could not resolve dependencies for project com.xyz:xyz-redesign.c
is:6.5.0: Failed to read artifact descriptor for com.adobe.aem:uber-jar:jar:apis:6.5.0: Could not transfer artifact com.adobe.
ntent/groups/public): Transfer failed for https://repo.adobe.com/nexus/content/groups/public/com/adobe/aem/uber-jar/6.5.0/uber
BuilderException: unable to find valid certification path to requested target

 

Can you explain why these arguments were required ?

Thanks again for your help !

Avatar

Community Advisor

Hey,

Try using the mvn -PautoInstallPackage -Padobe-public clean install
If issue still exists you try updating your settings/xml in .m2 folder.

I have the updated settings.xml which worked for me, you get it on my post settings.xml
I
t contains Adobe Public added to it.
It worked for me!!!