Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events
SOLVED

Maven build error after installing AEM-6.2-Service-Pack-1-6.2.SP1

Avatar

Level 1

We have been struggling with getting our Maven build process to work with AEM after installing 6.2 SP1, which requires the installation of two packages:

  1. cq-6.2.0-hotfix-12785-7.0
  2. AEM-6.2-Service-Pack-1-6.2.SP1

When we install the hotfix and service pack in sequence (without restarting AEM) the Touch UI loads fine.  We are able to restart AEM without issue.  When we run a Maven build against AEM, the content is imported and AEM continues to function.  Once AEM is restarted, however, the app throws a 500 error when anything other than CRXDE Lite is requested.

It's hard to know what to look for in the error logs, as there are nearly 60 error messages, but this IO Exception ('Unable to get component of class 'interface org.apache.sling.rewriter.Transformer') seems common to many error and is linked to the initial GET request for the Touch UI.

Here is the full message:

31.07.2017 10:20:18.027 *ERROR* [0:0:0:0:0:0:0:1 [1501521617450] GET /projects.html/content/projects HTTP/1.1] org.apache.sling.engine.impl.SlingRequestProcessorImpl service: Uncaught SlingException

java.io.IOException: Unable to get component of class 'interface org.apache.sling.rewriter.Transformer' with type 'versioned-clientlibs'.

Has anyone else experience this type of error?

1 Accepted Solution

Avatar

Correct answer by
Level 10

Hi,

I am not quite sure about the reason behind the issue but I have faced multiple times.

Place ACS Commons package in /crx-quickstart/install location, if the package installs properly ( check logs for this ), the issue should be resolved. Also, try to recompile JSP.

View solution in original post

2 Replies

Avatar

Correct answer by
Level 10

Hi,

I am not quite sure about the reason behind the issue but I have faced multiple times.

Place ACS Commons package in /crx-quickstart/install location, if the package installs properly ( check logs for this ), the issue should be resolved. Also, try to recompile JSP.