Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Marketo forms integration to AEMaaCS - JS not executed due to mime type

kimonp31365843
Level 4
Level 4

Hi everyone,

 

We have performed the Marketo forms integration into our local AEM as a Cloud Service author, as described in https://adobe-consulting-services.github.io/acs-aem-commons/features/marketo-form/index.html .

 

However, when attempting to view the embedded form, the cmponent does not appear at all, and we get the following error in our chrome console:

 

Screenshot 2021-10-07 at 12.05.28.png

 

This happens on a vanilla AEMaaCS author, with WKND sample website deployed. No dispatcher sits in between, so we simply access the instance via locahost URL.

 

Thank you in advance for your help.

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

1 Accepted Solution
kimonp31365843
Correct answer by
Level 4
Level 4

Well, it took me a good few hours but in the end the culprit was the Marketo host configuration; instead of the host used to log in marketo (e.g. engage-lon.marketo.com) you need to use the app host (e.g. app-lon10.marketo.com)

View solution in original post

1 Reply
kimonp31365843
Correct answer by
Level 4
Level 4

Well, it took me a good few hours but in the end the culprit was the Marketo host configuration; instead of the host used to log in marketo (e.g. engage-lon.marketo.com) you need to use the app host (e.g. app-lon10.marketo.com)

View solution in original post