Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events
SOLVED

LoadModule dispatcher_module Error

Avatar

Community Advisor

I am configuring dispatcher i my local environment and using 32 bit apache server,32 bit dipatcher.dll files and included dispatcher_module in httpd.conf

file when i am trying to to apache server it is throwing me an error attached the error screen shot 

Please can you help me how can we resolve it.

1 Accepted Solution

Avatar

Correct answer by
Employee Advisor

Hi,

On  [1] I don't find any binary for WIndows and Apache httpd 2.4. Which dispatcher do you use?

kind regards,
Jörg

[1] https://www.adobeaemcloud.com/content/companies/public/adobe/dispatcher/dispatcher.html

View solution in original post

8 Replies

Avatar

Correct answer by
Employee Advisor

Hi,

On  [1] I don't find any binary for WIndows and Apache httpd 2.4. Which dispatcher do you use?

kind regards,
Jörg

[1] https://www.adobeaemcloud.com/content/companies/public/adobe/dispatcher/dispatcher.html

Avatar

Community Advisor
Hi, I am using dispatcher 2.2 for windows OS

Avatar

Level 9

As per snapshot, it shows something wrong with the syntax. To find out the real cause, May i have configuration snippet added in httpd.conf for the dispatcher?.

Jitendra

Avatar

Community Advisor

Hi 

Please find the file attached Httpd.conf.

Avatar

Level 9

I found some of the configuration missing in your httpd config file. Follow instructions in below doc.

http://www.cqtutorial.com/courses/cq-admin/cq-admin-lessons/cq-dispatcher/cq-dispatcher-apache-set-u...

<IfModule disp_apache2.c> entry is missing/

Jitendra

Avatar

Community Advisor
        Ok thank you I ll verify it again

Avatar

Employee Advisor

Hi,

the screenshot shows "apache2.4.9", so I assume, that you use Apache 2.4; but then you need a dispatcher module built for Apache 2.4 for Windows, which is not available. Rather stay with Apache 2.2 for the moment and request a Windows build for Apache 2.4.

kind regards,
Jörg

Avatar

Community Advisor
        Thanks Jorg for your info .