Highlighted

Link checker ignoring all links

Sutty100

23-09-2019

We are trying to turn on the AEM link checker and I am seeing some strange behavior. If I create a new page in Sites and make any change to it e.g. add a new component or edit the properties dialog then the page itself will show up in the link checker e.g.

http://localhost:4502/mnt/overlay/wcm/core/content/sites/properties.html?item=%2Fcontent%foo%2Fen%2F...

or

http://localhost:4502/editor.html/content/foo/en/link-checking.html

However any links I add to the page are never shown in the link checker. This is on AEM 6.5.0 and seems to occur on our custom pages and also on We.Retail (image attached)

Screenshot 2019-09-23 at 18.08.40.png

My understanding from reading the docs and http://www.aemcq5tutorials.com/tutorials/aem-link-checker-comprehensive-guide/#aem-external-link-che... is that AEM should be parsing the JCR below an edited page for any property values that are formatted as links and pulling them out rather than the page itself.

Config for the link checker is unchanged from the default OOTB

Screenshot 2019-09-23 at 18.11.37.png

Replies

Highlighted

jbrar

Employee

23-09-2019

You can setup a DEBUG logger on "com.day.cq.rewriter.linkchecker" to get more info on why the links are not included and when does AEM check for new links.

Highlighted
Highlighted

ArpitVarshney

MVP

23-09-2019

As mentioned above, please open this Config in OSGi Configuration "Day CQ Link Checker Transformer" and make sure "Disable Checking" field should be unchecked.

1836986_pastedImage_0.png