Highlighted

Json files with i18n configuration not getting imported with eclipse

jorarteag

25-03-2018

Hi, im working with eclipse (last version) and its aem plugin, in crx I created a couple of files inside a component for its i18n configuration (i.e de.json, es.json) and that is working in my pages, but when I want to import that to my local filesystem with eclipse those files are not imported. I check my vault config and its fine, does not exclude any json file, and if I change the name of the file adding something after the .json, like de.json.original eclipsewill recognize that, but does not work in my pages.

At the moment happend just with this kind of files.

Its that a bug of the plugin? A wrong configuration in my ide?

Thanks in advance for any help.

Replies

Highlighted

jorarteag

26-03-2018

There are some images of the files in the crx, and whe I use the import functionality of the aem plugin for eclipse the i18n folder is still empty, this just its happening with json files with languague properties.

crxjson.png

propjson.png

emptyfolder.png

Highlighted

kautuk_sahni

Community Manager

10-04-2018

Reply from the Expert:

Can you:

1) Double check the filter.xml and ensure there is nothing that would prevent those files from being sync’d

2) Perform a test building the project (mvn clean install -PautoInstallPackage) and see if those files are included in that package.

If they are included in the package deployed in step 2, then it sounds like a  bug with AEM Dev Tools.

If they are not included in the package, then vlt is correct, and there is likely something fishy going on w the filter.xml or how those files are created/placed in the project.

-Kautuk

Highlighted

jorarteag

18-04-2018

I think there is a bug, vault does not have any configuration to avoid that, anyways now I am working without the json config to i18n, also I found other similar questions in the forum.

Thank you.