Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

[AEM Gems Webinar] Accelerating Experience Manager as a Cloud Service development with Rapid Development Environments
Adobe Summit 2023 | Complete list of AEM Sessions & Labs
SOLVED

java.lang.NoSuchMethodError: com.adobe.granite.auth.ims.ImsConfigProvider.getImsLoginUrl

Avatar

Level 4

while starting the AEM 6.4 on the error logs repeatedly the below error is printed.This occupies the entore log.please can you suggest if any configuration changes are required.

 

 

10.04.2020 12:11:30.564 *ERROR* [19.14.119.71 [1586535090563] GET /libs/granite/core/content/login.html HTTP/1.1] org.apache.sling.engine.impl.SlingRequestProcessorImpl service: Uncaught SlingException
java.lang.NoSuchMethodError: com.adobe.granite.auth.ims.ImsConfigProvider.getImsLoginUrl(Ljavax/servlet/http/HttpServletRequest;)Ljava/lang/String;
at org.apache.jsp.libs.granite.core.components.login.login_jsp._jspService(login_jsp.java:279)
at org.apache.sling.scripting.jsp.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70) [org.apache.sling.scripting.jsp:2.2.7.B002]
at javax.servlet.http.HttpServlet.service(HttpServlet.java:725) [org.apache.felix.http.servlet-api:1.1.2]
at org.apache.sling.scripting.jsp.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:502) [org.apache.sling.scripting.jsp:2.2.7.B002]

1 Accepted Solution

Avatar

Correct answer by
Administrator

Answered by Theo:

 

 

I've never had this problem but it looks like a bundle issue. As you can see here, the ImsConfigProvider does indeed have a getImsLoginUrl method, so this error is strange.

Can you check that you find com.adobe.granite.auth.ims.impl.ImsConfigProviderImpl among your active components by searching for it here: http://localhost:4502/system/console/components.

Also, make sure the Adobe Granite IMSAuthentication Handler bundle is in Active status here: http://localhost:4502/system/console/bundles

 

Thanks a lot,that helped.I restarted the bundle and it worked fine.Also disabled the  com.adobe.granite.auth.ims.impl.ImsConfigProviderImpl  in  http://localhost:4502/system/console/components. and made active.

This solved the issue.

 

View solution in original post

0 Replies

Avatar

Community Advisor

Hello,

Just a quick remark: in future, if you're looking for help from the community, just make sure to post as a Question and not as a Discussion 😉

I've never had this problem but it looks like a bundle issue. As you can see here, the ImsConfigProvider does indeed have a getImsLoginUrl method, so this error is strange.

Can you check that you find com.adobe.granite.auth.ims.impl.ImsConfigProviderImpl among your active components by searching for it here: http://localhost:4502/system/console/components.

Also, make sure the Adobe Granite IMSAuthentication Handler bundle is in Active status here: http://localhost:4502/system/console/bundles

Avatar

Level 4

Hi,

Thanks a lot,that helped.I restarted the bundle and it worked fine.Also disabled the  com.adobe.granite.auth.ims.impl.ImsConfigProviderImpl  in  http://localhost:4502/system/console/components. and made active.

This solved the issue.

Avatar

Correct answer by
Administrator

Answered by Theo:

 

 

I've never had this problem but it looks like a bundle issue. As you can see here, the ImsConfigProvider does indeed have a getImsLoginUrl method, so this error is strange.

Can you check that you find com.adobe.granite.auth.ims.impl.ImsConfigProviderImpl among your active components by searching for it here: http://localhost:4502/system/console/components.

Also, make sure the Adobe Granite IMSAuthentication Handler bundle is in Active status here: http://localhost:4502/system/console/bundles

 

Thanks a lot,that helped.I restarted the bundle and it worked fine.Also disabled the  com.adobe.granite.auth.ims.impl.ImsConfigProviderImpl  in  http://localhost:4502/system/console/components. and made active.

This solved the issue.