Expand my Community achievements bar.

July 31st AEM Gems Webinar: Elevate your AEM development to master the integration of private GitHub repositories within AEM Cloud Manager.
SOLVED

Issue with GIF images in publish -AEMaaCS

Avatar

Level 2

We see that GIF images are not getting replicated to the publish instance in AEM cloud environments. I have checked the replication agent log and its clear. 

When I used the GIF file in a image component, published the page and GIF image, I see that the image is not showing up in the publish site. When I checked the publish log, I saw the below error:

 

06.09.2022 12:24:44.477 [cm-p****-e526414-aem-publish-7ddc549f88-bl7bk] *ERROR* [49.204.215.80 [1662467083669] GET /content/*******/east-asia/******/en.html HTTP/1.1] com.adobe.cq.wcm.core.components.internal.models.v2.ImageImpl Unable to find resource '/content/dam/*********/east-asia/*****/public/en/images/products/8-3-electric-machine-design-problem.gif' used by image '/content/******/east-asia/*****/en/jcr:content/root/container/container/image_copy'.

 

I see that the image is in published status in the AEM assets console. It works fine in AEM local SDK but I'm seeing this strange issue only in the cloud environments. Is there any way we can further troubleshoot this?

1 Accepted Solution

Avatar

Correct answer by
Level 2

Just in case if anyone else is facing the issue, the solution was to correct the dispatcher  rules generated by AEM project architype. 

View solution in original post

1 Reply

Avatar

Correct answer by
Level 2

Just in case if anyone else is facing the issue, the solution was to correct the dispatcher  rules generated by AEM project architype.