Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Is AEM-Hybris connector production ready ?

Avatar

Level 2

Hi Guys,

I am following steps mentioned on http://dev.day.com/docs/en/cq/current/ecommerce/eCommerce-hybris.html

But there seems to be some serious version conflicts between packages, below are packages I have installed :

  • cq-hybris-content-5.6.2.zip  (CQ-Hyrbis-Connector)
  • cq-hybris-server-5.6.100.zip (Embedded hybris server)
  • cq-commerce-core-5.6.18.jar (OOTB installed commerce API)

It seems that connector code in cq-hybris-content-5.6.2.zip is not in sync with xml that is generated from cq-hybris-server-5.6.100.zip also I have tried using standalone hybris 5.0.4 server as suggested in link, both gives below error in error logs and nothing gets imported into CQ from hybris

06.05.2014 17:04:58.003 *INFO* [0:0:0:0:0:0:0:1 [1399376090918] POST /libs/commerce/products HTTP/1.1] com.adobe.cq.commerce.hybris.importer.DefaultHybrisImporter Skipping product due to missing base product information (code/path): null
06.05.2014 17:04:58.003 *ERROR* [0:0:0:0:0:0:0:1 [1399376090918] POST /libs/commerce/products HTTP/1.1] com.adobe.cq.commerce.hybris.importer.DefaultHybrisImporter E Skipping product due to missing base product information (code/path): null

Also if we see pom.xml of hybris-impl project in cq-hybris-content-5.6.2.zip it is dependent on commerce API version cq-commerce-core-5.6.16.jar which is different from OOTB version installed in CQ i.e cq-commerce-core-5.6.18.jar due to that I get lot of ScriptEvaluationException on JSP pages as there are some interface definition changes Eg:- : CommerceService.java and Product.java.

If I try to use cq-commerce-core-5.6.18.jar in cq-hybris-content-5.6.2.zip hybris-impl project than com.day.cq.commons.inherit.ComponentInheritanceValueMap does not gets resolved in HybrisServiceImpl.java as it has indirect dependency on com.day.cq.commons.inherit.ComponentInheritanceValueMap

Please can any one suggest which are stable/production ready combination of CQ-Hybris-Connector, Commere API and Hybris that can be used in new project.

Thanks,

Madhav

1 Accepted Solution

Avatar

Correct answer by
Employee

Hi

I am able to find cq-hybris-server version 5.6.200 on packageshare. I can also see cq-commerce-hybris-update 5.6.200 and cq-geometrixx-hybris-content 5.6.200.

It's probably an access right issue. You should request access via daycare as mentioned in the docs.

View solution in original post

4 Replies

Avatar

Level 10

Seems you are using an old version of the hybris embedded server can you try with new package 5.6.200

Avatar

Level 10

If you are following the AEM docs and running into these issues - looks like there is  a bug - please open a ticket here:

http://helpx.adobe.com/marketing-cloud/experience-manager.html

Avatar

Level 2

Hi Sham,

Thanks !

5.6.200 version of embedded Hybris server is not available on package share site, it only has 5.5.0, 5.6.0 and 5.6.100.

Also we would like to have standalone Hybris server, but as mentioned above connector code seems to be not in sync with xml that is generated by Hybris web-services.

Thanks,

Madhav

Avatar

Correct answer by
Employee

Hi

I am able to find cq-hybris-server version 5.6.200 on packageshare. I can also see cq-commerce-hybris-update 5.6.200 and cq-geometrixx-hybris-content 5.6.200.

It's probably an access right issue. You should request access via daycare as mentioned in the docs.