Highlighted

Indonesian language in AEM

JeremyJud

28-09-2017

I have what looks like an issue with the support of Indonesian language by AEM

AEM seems to expect the code "id"/"id_id" (like in wcm/core/resources/languages)

But Java provides the code "in_id" (see Java Supported Locales​, for example with currentPage.getLanguage(false))

It seems the issue has already reported there : MSM New language (Indonesian) vs Page.getLanguage() , but no answer.

I'd like to know what is the best approach to fix/workaround this issue.

Replies

Highlighted

markj1644785

10-08-2018

I am also curious if anyone got an answer? We are running into the same issue. We set up Indonesia in AEM as id_id and then we were having problems with our i18n file not working. We worked with Adobe support and that is when we found out the JAVA issue.

Highlighted

Ankur_Sial

12-11-2018

Hi,

This observation is due to Java's Locale class where "id" is replaced with "in". As a workaround, please use dictionaries with language in_id. In case you face more related issues, please let us know.

Highlighted

sgarg122001

22-01-2019

hi Jery,

We are also facing the same issue in our ongoing project can you please let me know if you got any update from day care or adobe to fix this issue.

Thanks

Sahil Garg

Highlighted

eugenen29508336

13-03-2019

I've managed to get this working by updating 2 locations:

1) /apps/wcm/core/resources/languages/in_id

2) /apps/<projectname>/i18n/id

For (1), I did not need to add a "defaultCountry" property to the node to get it working. This step will add "Indonesian" into the languages dropdown in page properties

For (2), you will need jcr:language as in-id and if you're invoking i18n from your servlets, make sure you're passing "in-id" as parameter to your resourceBundle when instantiating I18n object.

Highlighted

farahz913310

10-04-2019

I am trying to add i18n  for indonesian language.

I can see id in translator.html.But  indonesion language  does not work at component level.

I added "id" in etc/languages but still doesnt work.

Can anyone help me on this.

Thanks in advance.