Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Import wcm.core.components into my project

Avatar

Level 2

Hi all... I would like to make use of the core components (V 2.11.0) into my AEM project (V 6.5.4). I added the wcm components core, config and content dependencies into my poms and tried to extend the v1/container component, but I have the following error, "com.adobe.cq.wcm.core.components.models.LayoutContainer cannot be resolved to a type". I'm kind of lost here since my experience with AEM has been brief. Thanks in advance.

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Definitely you are facing dependency issue here.

If we take a look into this document: https://experienceleague.adobe.com/docs/experience-manager-core-components/using/versions.html?lang=... , it gives an overview of the releases of the Core Components and their compatibility with AEM releases and Java versions.

 

DEBAL_DAS_0-1646366711254.png

Dependencies: In order to use the 2.11.0 release, as a minimum, you will need an AEM 6.5.5.0 or AEM 6.4.8.1.

That's why you are facing this issue.

 

I am using 2.17.14 with AEM 6.5.9 -

DEBAL_DAS_1-1646366823515.png

 

Hope this will help.

View solution in original post

3 Replies

Avatar

Level 10

Hi @espinari , Can you navigate to /system/console/bundles and check if all bundles including core components bundles are active. If not try restarting you server and check if bundles are in active state.

Avatar

Correct answer by
Community Advisor

Definitely you are facing dependency issue here.

If we take a look into this document: https://experienceleague.adobe.com/docs/experience-manager-core-components/using/versions.html?lang=... , it gives an overview of the releases of the Core Components and their compatibility with AEM releases and Java versions.

 

DEBAL_DAS_0-1646366711254.png

Dependencies: In order to use the 2.11.0 release, as a minimum, you will need an AEM 6.5.5.0 or AEM 6.4.8.1.

That's why you are facing this issue.

 

I am using 2.17.14 with AEM 6.5.9 -

DEBAL_DAS_1-1646366823515.png

 

Hope this will help.

Avatar

Level 6

I second what @DEBAL_DAS is saying. Please do check the core component version compatibility with AEM version you are using.

 

Thanks