Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Impersonation doesn't work as expected in 6.5

Avatar

Level 2

Hello all, we are using the AMS for AEM 6.5. I am trying to test the impersonation, but it doesnt show any users. in /useradmin i made sure admin group has all the Read/Modify/Create/Delete/Read ACL/Edit ACL/Replicate are all checked. Basically this group has access to everything. Now i am an admin in that group and i am trying to impersonate a user with lower level permissions, but i am not able to see the user. What am i doing wrong here.. Also i made sure home/users is checked.

1 Accepted Solution

Avatar

Correct answer by
Level 2

To anyone if this helps, on /useradmin, its a drag and drop in impersonation.

View solution in original post

0 Replies

Avatar

Employee Advisor

Not sure if I fully understood the issue but try to go to /useradmin and add your user in the impersonators tab for the user you want to imperosnate

Screen Shot 2019-10-18 at 2.01.40 PM.png

Avatar

Level 2

Hello Jaideep, thank you and sorry for the confusion. I understand useradmin is an old UI which we were advised not to use (but i am still using it as new UI doesnt work at all).. In new UI, where can i set the impersonate users. As per this link User Administration and Security its says "In order for impersonating to work for non-admin users, the impersonator (in the above case user-B) is required to have READ permissions in the /home/users path." but its not working as expected.

Thus was the question. So if usera wants to impersonate userb, then userb should have usera as impersonate user. Right?

Does this apply for admins as well?

Also i dont see an option to add the user.

1845817_pastedImage_0.png

Avatar

Correct answer by
Level 2

To anyone if this helps, on /useradmin, its a drag and drop in impersonation.