Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.

IllegalStateException: Parent node not found while publishing content fragment

Avatar

Level 3

In attempting to publish content fragments there are a couple of pieces of content that cause the replication queue to be blocked with this error. 

Screenshot 2023-10-03 at 1.23.55 PM.png


Caused by: org.apache.jackrabbit.vault.packaging.PackageException: Error creating/updating node /content/dam/.../jcr:content at org.apache.jackrabbit.vault.fs.io.Importer.commit(Importer.java:1104) at org.apache.jackrabbit.vault.fs.io.Importer.commit(Importer.java:905) at org.apache.jackrabbit.vault.fs.io.Importer.commit(Importer.java:945) at org.apache.jackrabbit.vault.fs.io.Importer.commit(Importer.java:945) at org.apache.jackrabbit.vault.fs.io.Importer.commit(Importer.java:945) at org.apache.jackrabbit.vault.fs.io.Importer.commit(Importer.java:945) at org.apache.jackrabbit.vault.fs.io.Importer.commit(Importer.java:945) at org.apache.jackrabbit.vault.fs.io.Importer.commit(Importer.java:945) at org.apache.jackrabbit.vault.fs.io.Importer.commit(Importer.java:945) at org.apache.jackrabbit.vault.fs.io.Importer.commit(Importer.java:945) at org.apache.jackrabbit.vault.fs.io.Importer.commit(Importer.java:945) at org.apache.jackrabbit.vault.fs.io.Importer.commit(Importer.java:945) at org.apache.jackrabbit.vault.fs.io.Importer.run(Importer.java:511) ... 12 more

Caused by: java.lang.IllegalStateException: Parent node not found. at org.apache.jackrabbit.vault.fs.io.Importer.commit(Importer.java:1030) ... 24 more

Any idea what could cause this? The parent node would be the parent node of the content fragment, right? Other sibling content fragments publish fine. 

3 Replies

Avatar

Community Advisor

Can you check if parent node is present as during publishing it will try to add/update some jcr properties so looks for the complaining node in your crx/de

Avatar

Level 3

It's definitely there. Yesterday as a test I duplicated the content fragment itself, deleted the old one, then renamed the duplicate content fragment to be the same as the original one. That one published without issue. So it has to be something else, like a permissions issue or some setting that isn't visible in CRXDE Lite.

Avatar

Level 3

You need to check two scenarios here.

1. Check whether the parent node is published or not. if the parent node is not published we get these errors.

2. Check if any special characters are there in the node.