Expand my Community achievements bar.

Applications for the 2024-2025 Adobe Experience Manager Champion Program are open!
SOLVED

i'm facing this error while building for AEMaaCS

Avatar

Level 4

[ERROR] The analyser found the following errors for author and publish :
[ERROR] [api-regions-exportsimports] org.xhtmlrenderer:flying-saucer-pdf-itext5:9.1.22: Bundle flying-saucer-pdf-itext5:9.1.22 is importing package(s) [
Package com.itextpdf.text;version=[5.5,6), Package com.itextpdf.text.pdf;version=[5.5,6)] in start level 20 but no visible bundle is exporting these for
that start level in the required version range. (aem:sample:core-aemaacs.all:1.0.0-SNAPSHOT)
[ERROR] [api-regions-exportsimports] aem:sample:core-aemaacs.core:1.0.0-SNAPSHOT: Bundle core-aemaacs.core:1.0.0-SNAPSHOT is importing package(s) [co
m.maxmind.geoip2.model, com.maxmind.geoip2, com.maxmind.db, com.maxmind.geoip2.exception, com.adobe.acs.commons.email, com.maxmind.geoip2.record] in start level 20 but no bundle is exporting these for that start level.

 

Can anyone guid me that how to embed or export this dependency? or a way fix this issue?

i'm using 35v archetype.

 

 

1 Accepted Solution

Avatar

Correct answer by
Level 4

This issue resolved after make use of Export-Package in bnd-plugin

Export-Package

 

View solution in original post

9 Replies

Avatar

Employee Advisor

Hi @vkarthick ,

 

You need to make sure these bundles are embedded in the container (all) project, otherwise during runtime Cloud instance won't have these bundles to refer to. which is why you are seeing this error.

Make sure these bundles are embedded properly in the POM file of the container, you can refer to this article here.

https://myaemlearnings.blogspot.com/2021/08/embedding-third-party-dependencyosgi.html 

 

Hope this helps!

 

Regards,

Nitesh

Avatar

Community Advisor

@vkarthick  Add below dependencies in all pom.xml file (Version can be any your preffered one)

<dependency>
<groupId>com.itextpdf</groupId>
<artifactId>itextpdf</artifactId>
<version>5.5.13</version>
</dependency>

And also embed the depedency as below  

<embedded>
<groupId>com.itextpdf</groupId>
<artifactId>itextpdf</artifactId>
<target>/apps/xxxx/install</target>
</embedded>

Hope this works !!!!

Avatar

Level 4

Thanks, 

i have also had this issue

m.maxmind.geoip2.model, com.maxmind.geoip2, com.maxmind.db, com.maxmind.geoip2.exception, com.adobe.acs.commons.email, com.maxmind.geoip2.record] 

Avatar

Community Advisor

Is this happening on the local AEM cloud sdk jar or AEM as a cloud environment?

Avatar

Correct answer by
Level 4

This issue resolved after make use of Export-Package in bnd-plugin

Export-Package

 

Avatar

Level 2

@vkarthick  am also facing the same issue , could you please let us know how you have added in pom.xml ?

Avatar

Level 4

step 1:Go to core/pom.xml

step 2: please find the below plugin

bnd-maven-plugin

 step 3: Where add the packages as shown below

Export-Package: 
com.maxmind.geoip2;version="2.16.0",\
com.itextpdf;version="5.13.2",\

step 4: Try to build again and it should resolve the problem.