Expand my Community achievements bar.

SOLVED

Getting GeneratePdfServiceImpl dependency error while using com.adobe.aemfd:aemfd-client-sdk:6.0.718.jar

Avatar

Level 2

I have a requirement to convert the non-PDF assets to PDF assets. As per the suggestion i had installed aem-service-pkg-6.5.20.0.zip with adobe-aem-forms-addon-6.5.20.0-windows.zip.

 

https://experienceleague.adobe.com/en/docs/experience-manager-65/content/forms/install-aem-forms/osg...

 

I was trying to use below dependency for my custom implementation class (aemfd-client-sdk.png) to use GeneratePdfService Interface, but it doesn't have the GeneratePdfServiceImpl class in the jar file, so I am facing dependency error. Please see attached [dependency error.png]

 

<dependency>
<groupId>com.adobe.aemfd</groupId>
<artifactId>aemfd-client-sdk</artifactId>
<version>6.0.718</version>
</dependency>

 

As per adobe-aemfd-pdfg-core.png I need to use this jar dependency to make use of GeneratePdfServiceImpl class. I have also configured the required environment variables in the Dev author env of linux system. Can anyone suggest how I can proceed on this to fix the error.

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

1 Accepted Solution

Avatar

Correct answer by
Level 2

I got to know from few sources that DocumentConversion exception is known issue for non-PDF assets with SP19 and SP20 itseems. So, it was mentioned that the fix for the issue will be available in SP21 service pack release itseems.

View solution in original post

6 Replies

Avatar

Level 6

HI @Minion_J ,

As per the dependency error screenshot, could you check if the Apache OpenOffice is installed and  configured correctly ?

somensarkar_0-1711352192063.png

 

Ref:- https://experienceleague.adobe.com/en/docs/experience-manager-65/content/forms/install-aem-forms/osg...

 

Thanks,

Somen

 

Avatar

Level 2

Yes. Apache OpenOffice is installed and configured. Now I am facing the different error. Attaching the error logs for reference. Thanks for your Support.

Avatar

Level 6

Now the error is from  com.threeShare.thermokingAssetshare.core.services.impl.AssetServiceImpl.processDocument(AssetServiceImpl.java:442) 

 

Debug it further to resolve the same. For conversion some parameters are mandatory and some are optional. Check the below javadoc . It may help you in resolving the same :- 

https://developer.adobe.com/experience-manager/reference-materials/6-5/forms/javadocs/index.html?com...

 

Thanks,

SOmen

Avatar

Level 2

Attached the code snippet. at line# 442 the first two parameters are mandatory params. at line# 440 I am creating the Document object by passing the InputStream as a parameter instead of passing the File parameter. In one of the references, they had tried passing the File input as a parameter. Let me give a try with this.

 

Hope we may get the same Document object though we use InputStream as a parameter/File as a parameter.

What do you say?

Avatar

Community Advisor

@Minion_J ,Did you find the suggestions from users helpful? Please let us know if more information is required. Otherwise, please mark the answer as correct for posterity. If you have found out solution yourself, please share it with the community.

Avatar

Correct answer by
Level 2

I got to know from few sources that DocumentConversion exception is known issue for non-PDF assets with SP19 and SP20 itseems. So, it was mentioned that the fix for the issue will be available in SP21 service pack release itseems.