Replies

Avatar

Avatar
Springboard
Level 7
Prince_Shivhare
Level 7

Likes

123 likes

Total Posts

407 posts

Correct reply

65 solutions
Top badges earned
Springboard
Establish
Give Back 100
Boost 100
Validate 1
View profile

Avatar
Springboard
Level 7
Prince_Shivhare
Level 7

Likes

123 likes

Total Posts

407 posts

Correct reply

65 solutions
Top badges earned
Springboard
Establish
Give Back 100
Boost 100
Validate 1
View profile
Prince_Shivhare
Level 7

16-04-2019

as per my understanding it should not be archetype issue.

because I am working in AEM 6.3 and archetype 17. and we are able to work in sling models properly with core components.

Also I am not able to find the dependency of sling models here:

org.apache.sling.models.impl:

In core pom:

<dependency>

   <groupId>org.apache.sling</groupId>

   <artifactId>org.apache.sling.models.impl</artifactId>

   <scope>test</scope>

</dependency>

<dependency>

   <groupId>org.apache.sling</groupId>

   <artifactId>org.apache.sling.api</artifactId>

   <version>2.4.2</version>

</dependency>

Parent POM:

<dependency>

   <groupId>org.apache.sling</groupId>

   <artifactId>org.apache.sling.models.impl</artifactId>

   <version>1.3.0</version>

   <scope>test</scope>

</dependency>

Avatar

Avatar
Give Back 5
Level 1
sowmyas47494557
Level 1

Likes

0 likes

Total Posts

7 posts

Correct reply

0 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile

Avatar
Give Back 5
Level 1
sowmyas47494557
Level 1

Likes

0 likes

Total Posts

7 posts

Correct reply

0 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
sowmyas47494557
Level 1

17-04-2019

I have never used this dependency before (org.apache.sling.models.impl). But I did try it by adding these dependencies mentioned, however I still get the error.

But I tried to create another Project with archetype 13 and the sling model worked fine.

Avatar

Avatar
Give Back 5
Level 1
sowmyas47494557
Level 1

Likes

0 likes

Total Posts

7 posts

Correct reply

0 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile

Avatar
Give Back 5
Level 1
sowmyas47494557
Level 1

Likes

0 likes

Total Posts

7 posts

Correct reply

0 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
sowmyas47494557
Level 1

17-04-2019

Is there any significance on the package name? Whenever I create a Project with package name as com.adobe.aem, it resolves to this error irrespective of the Archetype. I tried to create projects with archetype 13 and 15 under another package name and it works fine.