Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Getting 404 while loading experience fragment in DNS userinfo.json and undefined

Avatar

Level 3

keshava219_0-1652440975740.png

Getting 404 while loading experience fragment in DNS userinfo.json and undefined

 

but working in author mode please let me know how to handle this 404 

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hi @keshava219 
It is giving a 404 error which means not found.

Click on this request and try to see the path which it is trying to access and check:

  • check whether it is accessible in publisher or not, if not that means your experience fragment is not published. Please publish and check again.
  • If it's already published and can be accessed at the publisher then your dispatcher is blocking it. Check dispatcher logs and allow it.

Regards,

Arpit V

View solution in original post

0 Replies

Avatar

Community Advisor

Hi @keshava219 ,

 

Could you please share what is the exact use case?. If you want to expose your experience fragment in JSON then you can simply publish your experience fragment and remove editor.html from the URL then add fragmentname.model.json.

 

e.g.

Consider this is your EF.

http://localhost:4502/editor.html/content/experience-fragments/my-site/recipes/master.html

 

then URL should be like this

 

http://localhost:4502/content/experience-fragments/my-site/recipes/master.model.json

 

MayurSatav_0-1652444132112.png

 

 

Avatar

Level 3

hi @MayurSatav ,

 

            this experience fragment included on any a page and in that page we are calling experience fragment as a button option, So while loading EF we are facing time loading issue of "userinfo.json" taking 10 sec max time  of loading.

 

 

Avatar

Correct answer by
Community Advisor

Hi @keshava219 
It is giving a 404 error which means not found.

Click on this request and try to see the path which it is trying to access and check:

  • check whether it is accessible in publisher or not, if not that means your experience fragment is not published. Please publish and check again.
  • If it's already published and can be accessed at the publisher then your dispatcher is blocking it. Check dispatcher logs and allow it.

Regards,

Arpit V

Avatar

Level 3

Hi @ArpitVarshney ,

 

             Thanks a lot working fine now. but undefined still showing on both author and dispatcher

keshava219_0-1652857322687.png