Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Foundation Tags components or extended Tags component not working in Dispatcher?

Avatar

Level 4

Hi,

I have extended foundation Tags component for my requirement. It works in Author and Publish. But it doesn't work in dispatcher, it give some alert saying "" and if i click ok it redirects to dispatcher login page.

What i found is the EXT js code used in Tags component is causing the issue. But i don't know the alternate to make it work.

How can i make it work?.

Thanks.

Vikram.

1 Accepted Solution

Avatar

Correct answer by
Level 10

File daycare. As a temp workaround Your description says working in author & publish but not at dispatcher.   Are you sure you have not logged in publish Or is the tag used for authenticated user.  Two steps should solve the issue. 

*   Make sure user have read access to /libs/wcm/core/content/pageinfo  (You might already have)

*     In dispatcher you should allow for  /libs/wcm/core/content/pageinfo

View solution in original post

0 Replies

Avatar

Level 4

The js alert was "Your request could not be completed because you have been signed out" and if i click on Ok, it redirects to Log-in page

if i comment the ext js code in tags component /libs/foundation/components/form/tags/tags.jsp line 94 to 123, i don't get the alert but the component is not rendered.

Thanks,

Vikram

Avatar

Level 10

might be your custom code trying to access protected nodes.

Avatar

Level 4

HI Sham,

No customization was done. it was the same component there in foundation and just copied to apps. I tried using the both overlayed and foundation components. It doesn't work.

Avatar

Correct answer by
Level 10

File daycare. As a temp workaround Your description says working in author & publish but not at dispatcher.   Are you sure you have not logged in publish Or is the tag used for authenticated user.  Two steps should solve the issue. 

*   Make sure user have read access to /libs/wcm/core/content/pageinfo  (You might already have)

*     In dispatcher you should allow for  /libs/wcm/core/content/pageinfo

Avatar

Level 4

I will try this and let you know.

Thanks Sham.