Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events
SOLVED

Forum Emails no longer being sent in 5.6.1

Avatar

Level 2

We are running CQ 5.6.1 with CQ Social Communities package 1.4.205.  We have configured our Forum email notification as it is described in the Adobe docs [1].  We have also created our own ForumEventEmailBuilder that extends AbstractEmailBuilder.  We have disabled the out of the box com.adobe.cq.social.forum.impl.ForumEventEmailBuilder by unchecking the "Is Enabled" checkbox in the Felix console and ensured ours is enabled.

This all works great in our test environment and it worked great in our production environment until about a week ago when our EmailBuilder stopped getting called.  The out of the box one is not getting called either.  It lead me to believe that something got blacklisted in the Felix EventAdmin but we have our class package in the "Ignore Timeouts" section of the event admin as well as the com.adobe* in the Ignore Timeouts.

Email is being sent for Workflow events and Page events, it's just not getting fired for Forum events.  What could I be missing?  Is there somewhere in the system I can look to see why the Forum events are not triggering anything in the EventAdmin?

[1] https://docs.adobe.com/docs/en/cq/5-6-1/administering/notification.html

1 Accepted Solution

Avatar

Correct answer by
Level 9

I would suggset opening a support ticket.

- JK

View solution in original post

4 Replies

Avatar

Level 2

I should also comment that our production author application is bounced nightly for a backup so just bouncing the server doesn't seem to resolve the issue.

Avatar

Correct answer by
Level 9

I would suggset opening a support ticket.

- JK

Avatar

Level 9

I have new information.

If you read http://stackoverflow.com/questions/14973790/blacklisting-servicereference it sounds like you need to use timeout=0 to avoid blacklisting, not “ignore timeouts”.

Look for the warning mentioned to see if there is blacklisting. If so, the preferred answer is to use jobs: http://stackoverflow.com/questions/19513315/how-to-avoid-blacklisting-my-eventhandler-through-apache...

- JK

Avatar

Level 2

JK, that seemed to do the trick.  Since this is using an EmailBuilder to send the notification email I'm not sure how we would change it to a job.  We'll investigate however.