Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Felix Servlet Filter not shown in status-httpwhiteboard console

NaziyaP
Level 2
Level 2

Hi All,

I have been following the sample code from acs-aem-samples/SampleServletFilter.java at master · Adobe-Consulting-Services/acs-aem-samples · Git...  for a felix servlet filter . I have copied exact same code in my workspace without any changes . When I upload the bundle and hit http://localhost:4502/system/console/status-httpwhiteboard , I don't see my filter registered under Registered Filter Services. Neither is my filter called in any scenario, I have added loggers to verify the same.

Is there any other configuration or property that needs to be set , apart from what is mentioned in the sample code?

1 Accepted Solution
Arun_Patidar
Correct answer by
Community Advisor
Community Advisor

Hi,

Can you check if your bundle or service is active or not? if yes try to access any html page.

check another sample filter if helps:

aem63app-repo/CustomScreenFilter.java at master · arunpatidar02/aem63app-repo · GitHub

To know more about what is in the filter please check

Apache Sling :: Servlet Filter Support

View solution in original post

2 Replies
Arun_Patidar
Correct answer by
Community Advisor
Community Advisor

Hi,

Can you check if your bundle or service is active or not? if yes try to access any html page.

check another sample filter if helps:

aem63app-repo/CustomScreenFilter.java at master · arunpatidar02/aem63app-repo · GitHub

To know more about what is in the filter please check

Apache Sling :: Servlet Filter Support

View solution in original post

nico40468
Level 1
Level 1
Hi Arun, I tried the CustomScreenFilter but it seems not "installed". what I did is first put it in core project, and then build / autoInstallPackage it into AEM. But I cannot find it from aem console. and when I put breakpoint into CustomScreenFilter it didn't stop as well. Did I miss something? Would filter need extra config ?