Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

fbprofiledata and twitterprofiledata loader.json is taking too much of time to load

Naren1925
Level 2
Level 2

While examining our site traffic through New Relic(Performance Monitor Tool), I see the below transactions are one of the time consuming ones.

10.148.119.171 - anonymous 30/Sep/2016:15:45:29 +0000 "GET /etc/clientcontext/default/contextstores/fbprofiledata/loader.json?authorizableId=anonymous HTTP/1.1" 200 63 "https://www.lexmark.com/es_mx.html" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.116 Safari/537.36"

10.148.119.171 - anonymous 30/Sep/2016:15:45:33 +0000 "GET /etc/clientcontext/default/contextstores/twitterprofiledata/loader.json?authorizableId=anonymous HTTP/1.1" 200 64 "http://www.lexmark.com/en_us.html" "Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko"

I see these request in the browser Network Tab as well. These calls happen on each page. Both are related to social and We had this issue even when we migrated to 6.1 from 5.6.1. Right now we are on 6.1 with SP1. At that time Adobe has provided a hotfix. But looks like it is still didn't resolved the problem. If anybody has seen this issue and did some fix, please provide me the steps. I want to know if there is a way to turn this off.

HotFix: OverlayPackage_Twitter_Facebook_Salesforce-1.0.zip

I am not able to attach the hotfix. 

6 Replies
smacdonald2008
Level 10
Level 10

I asked our support team to look at this - generally if you have hotfix concerns - better to log a ticket as support can answer hotfix questions. 

Naren1925
Level 2
Level 2

Thanks Scott. I will have a ticket with Support team, but they take 3-4 days to reply back as this is not P1 or P2 according to their set of rules :). So thought of asking in open forum, so if anybody has the same issue they can help me with.

vmehrotr
Employee
Employee

Workaround - delete in /libs (that is not release update save):

/libs/social/personalization/contextstores/facebook/fbinterests/clientlib
/libs/social/personalization/contextstores/facebook/fbprofiledata/clientlib
/libs/social/personalization/contextstores/twitter/twitterprofiledata/clientlib
/libs/mcm/salesforce/components/salesforceprofiledata/clientlib

Touch /libs/cq/personalization/components/clientcontext/clientlib/kernel/js.txt so the clientlibs gets updated

Naren1925
Level 2
Level 2

Thanks Varun. I will check this option and will update here. I will also log a ticket with Adobe Support to see if they have any other view on this besides the workaround you suggested.

kautuk_sahni
Employee
Employee

Hi

See similar problem posted earlier :- http://help-forums.adobe.com/content/adobeforums/en/experience-manager-forum/adobe-experience-manage...

 // Please create a ticket with support team and meanwhile can use a workaround of disableing twitterprofiledata, fbprofiledata, fbinterestsdata

~kautuk

Naren1925
Level 2
Level 2

Hi Kautuk,

Thanks for the post. But I couldn't find any solution on that post. I had a day care ticket and Varun Mehrotra replied with his inputs and he also asked me to check with the same 5.6.1 hotfix-3930 to see if that fixes in 6.1. I am not sure if Adobe is having hotfix for 6.1. If so, it would be helpful.

Thanks.

Narendra N