Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

Existing AEM workflow Default Route

sunitac2231600
Level 4
Level 4

Hi All,

I have an existing workflow called ABC. It contains 2 branches. Now I want to set the branch 1 as my Default route

So I had selected the checkbox as shown in below screenshot.

But Still branch 2 is showing as default branch. After change the workflow I saved it also. Do I need to restart the Author instance ?

Please help me on this.

Thanks

5 Replies
aheim02
Employee
Employee

Just to check - is branch 2 still showing as the Default Route on a new instance of your workflow?

And which version of AEM are you using?

bsloki
Community Advisor
Community Advisor

Restart is not required. Which AEM version are you trying. I will try once and let you know if its a problem with my instance aswell.

Meanwhile, try on a new workflow model and see if you are still facing the issue.

sunitac2231600
Level 4
Level 4

Hi All,

I am using AEM 6.1.

If I am trying on new workflow model its working fine. But If I am trying to change in existing Workflow model, then It is not coming fine.

Yes, still branch 2 is showing as the Default Route on a new instance of the workflow, after I changed branch 1 as default.

bsloki
Community Advisor
Community Advisor

Hi Sunita,

I tried on both AEM 6.1 and AEM 6.2 and it is working fine for me. Steps followed

1. Create a new Workflow model

2. Add an OR Split. Select branch1 as default route. Save

3. Open the OR split properties, I still see the default route as branch1. Change it to branch 2. Save and Close

4. Open the workflow model again. See the properties and it is showing as branch2 as the default route.

Let us know if you are following anything different or if I am missing something here.

sunitac2231600
Level 4
Level 4

Hi All,

Thanks a lot for your help.

Please find my comments in bold. Still now Issue is not solved.

1. Create a new Workflow model
This is fine

2. Add an OR Split. Select branch1 as default route. Save
This is also fine

3. Open the OR split properties, I still see the default route as branch1. Change it to branch 2. Save and Close
This is also fine.

4. Open the workflow model again. See the properties and it is showing as branch2 as the default route.
This is also fine. Upto thi steps fine. But the issue happens after this.

After completed this all steps, I start workflow for one of websites from siteadmin. Then I went to AEM Workflow Inbox and right click on workflow and try to complete the workflow task. Here I am seeing in drop down by default as branch1 . But I should see by default branch2 in my drop down as shown in below screenshot.