Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.
SOLVED

Error while installing eclipse developer tools

Avatar

Level 1

While installing the eclipse developer tool; I got the following error:-

 

Cannot complete the install because one or more required items could not be found.
  Software being installed: Sling IDE Tools 1.0.2 (org.apache.sling.ide.feature.feature.group 1.0.2)
  Missing requirement: org.apache.sling.ide.impl-vlt 1.0.2 requires 'package org.osgi.framework 1.7.0' but it could not be found
  Cannot satisfy dependency:
    From: Sling IDE Tools 1.0.2 (org.apache.sling.ide.feature.feature.group 1.0.2)
    To: org.apache.sling.ide.impl-vlt [1.0.2]

 

 

Steps I followed:-

Opened the Help menu in eclipse.

Clicked on Install new software

Copied the installation URL 'http://eclipse.adobe.com/aem/dev-tools/'  

Checked both sling and AEM plugins

Clicked next.

 

Then I got the above mentioned error. Did anybody else get this error?

Thanks

1 Accepted Solution

Avatar

Correct answer by
Level 6

What version of Eclipse are you using? The reason you get this might be that the OSGi framework in your Eclipse is to old. I get this to work perfeclty well with 4.4.

/O

View solution in original post

2 Replies

Avatar

Correct answer by
Level 6

What version of Eclipse are you using? The reason you get this might be that the OSGi framework in your Eclipse is to old. I get this to work perfeclty well with 4.4.

/O

Avatar

Level 1

I downloaded and installed 4.4 version of eclipse and was able to install developer tools.

Thanks for the response.