Effective Access Control Policies empty

Avatar

Avatar

johnnyd26246076

Avatar

johnnyd26246076

johnnyd26246076

20-09-2017

Hi all,

We noticed in our AEM 6.2 and AEM 6.3 instances that when we click on a content node in crx/de that the section "Effective Access Control Policies" on the bottom right pane is always empty.

Compared to AEM 5.6 we could see the "Effective Access Control Policies" containing the node's access control list and the inherited ones.

I could not find anything back in the documentation that mentions something about this. I'm also not sure if this is only a visualisation issue or that the node effectively doesn't inherit the ACL's from its parent node.

Thanks for all the help.

Johnny

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

vaibhavvs09

Avatar

vaibhavvs09

vaibhavvs09

22-09-2017

Effective Access Control Policies panel was removed in AEM 6.2 due to performance issue.

There is a workaround for this in form of “Test Access Control” which can be accessed from localhost:<port>/crx/explorer.

Answers (3)

Answers (3)

Avatar

Avatar

nschmuter

Avatar

nschmuter

nschmuter

02-07-2018

Are there any plans for re-adding this feature or adding something similar. Working with "Test Access Control" is a good workaround, but it was a very clear way to check the Effective ACL panel.

Thank you!

Avatar

Avatar

kautuk_sahni

Community Manager

Total Posts

5.6K

Likes

965

Correct Answer

1.1K

Avatar

kautuk_sahni

Community Manager

Total Posts

5.6K

Likes

965

Correct Answer

1.1K
kautuk_sahni
Community Manager

22-09-2017

This is something known and I have asked an internal expert to share some information on this with you.

~kautuk

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K
smacdonald2008

20-09-2017

Please post a screen shot.