Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.
SOLVED

Do we need to install latest ACS commons package after AEM upgrade 6.5.18?

Avatar

Level 2

Hi Team,

 

In my current project, we have upgraded AEM 6.5.9 to 6.5.18.

ACS commons current version is 5.0.4

 

Now, we are facing some multifield-related issues. (Unable to store the dialog fields once saved.) We have many components that have stored the multifield in JSON format as well as in node structure.

 

In some of the Adobe articles, they mention upgrading ACS Commons too.

Could you please confirm if we need to upgrade ACS Commons versions along with the AEM upgrade?

 

 

Thanks in advanced!

Nikita M.

1 Accepted Solution

Avatar

Correct answer by
Level 8

Hi @Nikita_Mazire ,

Some of the package which is installed on your AEM instance is not compatible w/ ACS-version. Please check what all package you have applied apart from SP 18, may be SSP(security patch) package installed could also break this.
Also try replacing the underscore with acs-commons.loadash as suggested in below blog:

https://github.com/Adobe-Consulting-Services/acs-aem-commons/issues/2821?secureweb=Teams&secureweb=T...

Thanks
Tarun

 

View solution in original post

12 Replies

Avatar

Employee Advisor

Hi @Nikita_Mazire!

I'm not aware of a dependency between the latest AEM service pack and a specific version of ACS Commons.

What version of ACS Commons are you currently using?

 

I'd recommend to run a quick test (e. g. on a local development environment) if an upgrade of ACS Commons fixes the issue. That will most probably be the fastest way to get clarity.

In general, it's always a good idea to keep all parts of the software, including tools and libraries, up-to-date to benefit from new features and latest fixes.

 

Hope that helps!

Avatar

Level 4

hi @Nikita_Mazire - kindly update which acs version you are currently on with AEM 6.5.9

Avatar

Level 2

Thanks for your response. @NehaCMS 

We are using ACS commons version 5.0.4

Avatar

Level 6

Hello @Nikita_Mazire 

Referring to the compatibility chart, it seems that the suggestion for AEM version 6.5.10+ is to use ACS Commons version 6.x.x. It seems to be a good time for you to upgrade ACS commons to the latest version.

 

Compatibility chart: https://adobe-consulting-services.github.io/acs-aem-commons/pages/compatibility.html

 

regards,

Preetpal

Avatar

Community Advisor

Hello @Nikita_Mazire 

 

As everyone else suggested, please plan to upgrade ACS commons too.

  • You would be able to access recently added features
  • You would have recent fixes also available

 

But, while you would get additional benefits, I would request you to also validate the features of ACS commons that your project is currently using. Just to rule out deprecation/change of any feature.


Aanchal Sikka

Avatar

Level 8

Hi @Nikita_Mazire ,

As per the compatibility chart "https://adobe-consulting-services.github.io/acs-aem-commons/pages/compatibility.html"  , ACS commons version  5.0.4 does support AEM 6.5.18. The multifiled issue that you are seeing it could be due to error in multifield js provided by ACS-commons. Can you check if you have applied any other patch apart from AEM upgrade.
Also look into the browser console as what is breaking in JS.
If nothing works then you can try updating to latest version of ACS-common.


Thanks
Tarun

Avatar

Level 2

Thanks @TarunKumar  

You catch it well, ACS commons version  5.0.4 does support AEM 6.5.18

I've installed ACS Commons upgrade to 6.2.0 in my local, but still the same JS issue persists.

 

Facing a multifield JS issue after upgrading AEM 6.5.18

I've attached a snippet below from the console error. 

We've multiple components with data storage in JSON as well as in nodes format. (I hope we'll not lose content from MultiField.)

 

Nikita_Mazire_0-1700485543987.png

Nikita_Mazire_0-1700486482853.png

 

Any quick solution for this? Maybe we can add some global JS change 

Avatar

Correct answer by
Level 8

Hi @Nikita_Mazire ,

Some of the package which is installed on your AEM instance is not compatible w/ ACS-version. Please check what all package you have applied apart from SP 18, may be SSP(security patch) package installed could also break this.
Also try replacing the underscore with acs-commons.loadash as suggested in below blog:

https://github.com/Adobe-Consulting-Services/acs-aem-commons/issues/2821?secureweb=Teams&secureweb=T...

Thanks
Tarun

 

Avatar

Level 2

Yeah, thats correct by adding embed: acs-commons.lodash to /apps/acs-commons/touchui-widgets/composite-multifield

It's working fine!

The data got stored after saving the dialog.

Thank you very much!

 

Best regards,

Nikita M.

Avatar

Administrator

@Nikita_Mazire Did you find the suggestions from users helpful? Please let us know if more information is required. Otherwise, please mark the answer as correct for posterity. If you have found out solution yourself, please share it with the community.



Kautuk Sahni