Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Designs are storing under /libs by default

Maddy737
Level 4
Level 4

Dear All,

We have migrated to AEM 6.4 recently and as part of it we have done the repository restructuring. All the designs have moved to /apps/settings/wcm/desings/default from /etc/designs.

 

However, all the desings are storing under /libs/settings/wcm/desings/default instead of /apps. Generally, if /etc/designs does not exists, it should pick /apps this is not the case with me. 

 

How can i ensure the designs are picked/stored from /apps without using cq:designpath property?

 

Thanks you very much in advance.

1 Accepted Solution
Arun_Patidar
Correct answer by
Community Advisor
Community Advisor

Hi,

Restructuring guidance says -

  • For any Designs that are managed in SCM, and not written to at run-time via Design Dialogs.
  • Copy the designs from the Previous Location to the New Location ( /apps ).
  • Convert any CSS, JavaScript and static resources in the Design to a Client Library with allowProxy = true .
  • Update references to the Previous Location in the cq:designPath property.
  • Update any Pages referencing the Previous Location to use the new Client Library category (this requires updating Page implementation code).
  • Update AEM Dispatcher rules to allow serving of Client Libraries via the /etc.clientlibs/ proxy servlet.
  • For any Designs that NOT managed in SCM, and modified run-time via Design Dialogs
  • Do not move author-able Designs out of /etc .

To map dialog inside etc to apps dialog, you can use sling mapping, where /etc/design/yourpath redirect to /apps/settings/wcm/desings/default

View solution in original post

2 Replies
Arun_Patidar
Correct answer by
Community Advisor
Community Advisor

Hi,

Restructuring guidance says -

  • For any Designs that are managed in SCM, and not written to at run-time via Design Dialogs.
  • Copy the designs from the Previous Location to the New Location ( /apps ).
  • Convert any CSS, JavaScript and static resources in the Design to a Client Library with allowProxy = true .
  • Update references to the Previous Location in the cq:designPath property.
  • Update any Pages referencing the Previous Location to use the new Client Library category (this requires updating Page implementation code).
  • Update AEM Dispatcher rules to allow serving of Client Libraries via the /etc.clientlibs/ proxy servlet.
  • For any Designs that NOT managed in SCM, and modified run-time via Design Dialogs
  • Do not move author-able Designs out of /etc .

To map dialog inside etc to apps dialog, you can use sling mapping, where /etc/design/yourpath redirect to /apps/settings/wcm/desings/default

View solution in original post

shajiahmed
Level 3
Level 3

I am also facing the same issue, did you find answer to the issue I have set the design property in the page to /apps path, however it still uses /libs